Personal Water Craft Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
I just bought a 750sx. I don't know a lot about it. There are two black fittings on the nose of the ski. I know the one on the left is the bypass outlet. When I first started it there was no water coming out and I found that the fitting was plugged. I cleaned it out and now there is water flow but I don't know how much flow its supposed to have? It is a steady stream but only shoots out about an inch and runs down the bumper. Also, what is the fitting on the right side for? It bubbles occasionally with the engine running but nothing comes out, is that normal? Is there a bilge pump on a 750sx?
 

·
Registered
Joined
·
298 Posts
I have never seen one on the right hand side, but the one on the left should shoot a little further at idle, and quite a bit when going. About 6-9 inches out give or take. It should have a small white plastic box down by the impeller shaft. What does the one on the right look like, and what is it attached to? Did you clean the hose as well as the fitting on the left?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
The fitting on the right looks exactly the same as the left one and I figured out what it is for. It is a vent for the fuel cap compartment. What is the white plastic box by the impeller shaft? I haven't had a chance to clean the hose out for the left side to see if the flow improves.
 

·
Registered
Joined
·
298 Posts
That white box is the bilge. Yeah I have not ever seen one on the right, my 550 comes up through the hand pole, and I really haven't looked at that type of stuff on my 800
 
1 - 7 of 7 Posts
Top