Personal Water Craft Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Howdy,
I have a 95 SeaDoo GTS which has been a pretty good PWC until recently. Everytime we get back from taking it out, the hull is filled with water. The drain plug is in and works, and there are no cracks in the hull or hood. Any idea what might be causing this?? The only thing I can think of is it might be the rubber seal around the hood or seat.

Thanks!!
 

·
Registered
Joined
·
2 Posts
95 GTX Taking on Water

Check the sand cast plug in the exaust manifold. I have 2 of the 95s and both leaked. You can grind the old ones out and weld in new alum plugs in its place.
 

·
Registered
Joined
·
2 Posts
95 SeaDoo XP taking on water

I am new to the PWC world. I recently purchased 2 used 95 xp's and took them to the lake for the first time today. They both ran strong at first, but one of them took on a lot of water. The plug was in and tight. I drained all the water from the hull, replaced the plug and let it sit in the water for a while. No water went into the hull while it was just floating in the water. It started up and seemed to run fine. I rode it for a short time then stopped to check for water. Again several inches in the hull in just a short time!?!? The other issues I have with both ski's is that the VTS does not work. How do you set them to neutral???? Also the one that took on the water doesn't turn very well at all to the left, but does ok to the right. Any ideas??? As far as the VTS one of them the guage shows it all the way down, and the one that doesn't turn shows it all the way up. Thanks.
 
1 - 3 of 3 Posts
Top