Personal Water Craft Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello newbee here i just got a 96 seedoo gtx it runs great has a little smoke but nothing bad but it will not go dosent lose any power no strange noises or anything that seem be wrong would this be the impeller ? previous owner said it takes on a little water and wasent sure where it came from wear ring seems to look good lost at this point please help
 

·
Registered
Joined
·
3 Posts
Sounds as if the drive shaft or impeller has a problem, if it takes on alittle water as the other owner stated, you need to look at the rear of the engine and see if the drive shaft is in and will turn. Pull the spark plugs out and turn the engine by hand at the same time have a friend look into the rear to see if the imeller is turning. If the impeller is turning while you are turning by hand tell your friend to push a small stick in and see if the impeller stops while your turning it. Let me know what you find!
Ken
 

·
Registered
Joined
·
227 Posts
The water issue could be the carbon ring on your driveshaft not sealing right. Could also be loose exhaust, bad hose, something to that effect. Run it with the seat removed and look around. Could be just the bailer tubes aren't high enough. Does it rev up but feeling like its just spinning in place? That's cavitation and you'd need a pump wear ring. If you can't get full rpms, then a few things could be wrong. Let us know what you find.
 
1 - 4 of 4 Posts
Top