Personal Water Craft Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello!! I recently purchased a 96 770 Monte Carlo that had been garaged a long time possibly 5 years. I removed all old gas replaced it with High grade premium fuel connected water hose to flush kit and ran engine. I then took it took lake ran fine but even at full throttle would never get up on plane. Seems restricted engine sounds restricted in water but not out of water. Any suggestions? Thanks for any help!:confused:
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Update: Tigershark will not plane

First thanks for the suggestion rollo450, I did check the bearings and they had some grease still there, and I added more. I have also rebuilt carbs, changed spark plugs,and changed fuel filter but still no change, still runs and idles fine out of water but not enough power to plane out once at the lake, will not even idle with out some throttle help. I noticed today after my test run that there was additional water inside the hull so I checked water hoses and found that the exhaust manifold was dripping ( could be cracked not sure yet.)Does anyone know if this could be my problem? Could the restriction be a exhaust issue? Thanks for any HELP!!!:dunno:
 

·
Registered
Joined
·
37 Posts
check for an exhaust leak in the engine compartment area.

Take off seat and start up see if exhaust is in engine compartment, mine had the same thing and it was choking out the motor. Good Luck
 
1 - 4 of 4 Posts
Top