Personal Water Craft Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Newby here, I have had a battery drain issue. Here's the deal. I purchased this sl1050 from someone who rolled it and had the mfd/display replaced. Since then, the display will not time out or it will stay on for days until I unhook the battery. I hook it up it is off until I plug in the lanyard. Not sure if this is the only drain but is one issue. Any suggestions on this or how to re-program the timeout??

Also, I replaced the battery over the weekend (didn't let it charge 16hrs since my charger said it was fully charged after two hours. I know, dumb. Anyway, once I hooked it up, the small ground wire hooked to battery going into the box smoked and melted the cover which leads me to believe I have a dead short somewhere or was this because the battery wasn't fully charged, etc. The display said 12.8 volts. I am not sure why I have two ground wires anyway, but any suggestions on how to proceed are greatly appreciated...
 

·
Registered
Joined
·
8 Posts
Hm. Well, I don't know if this helps but here is my two cents. I recently bought a 96' sl 900 that had the very same ground wire fried when I got it, it wouldn't turn over or anything obviously. So I opened the electronics box and replaced the ground wire, it would start up but the display still wouldn't work so I went back into the box and checked the main fuse in there, it looked perfect but completely failed a continuity test. After replacing it the display works fine but it also does not turn completely off, ever. It always displays the time and if you hit the mode button everything lights up, this is without the key in. Anyways I don't know that they ever turn completely off, I have since then had it out a bunch of times and have had no problems with the ground wire frying or the battery going dead. Hope this helps?
 
1 - 2 of 2 Posts
Top