Personal Water Craft Forum banner

1 - 3 of 3 Posts

·
Premium Member
Joined
·
354 Posts
Discussion Starter #1
Hey all,

I just got 2 new batteries for both of my jet ski's so they will be ready to go for the summer. Here is what is weird though. Last year when it got really cold, my warning light on my 99' Kawasaki Ultra 150 started blinking even though the jet ski was completely turned off. When I turned it on to start it, it had a dead battery and I figured it was because it got too cold outside and the battery had died and the warning light was just letting me know. Well, both batteries to my jet ski's were still under warranty so I got them replaced yesterday and installed them. The one on my stand up jet ski did great. However, on my Ultra 150, when I was installing the battery, The little eye ring attached to the battery cable that the small bolt goes through to bolt into the battery, snapped off of the positive cable. I went down and got a brass replacement from my auto parts store but had to solder the battery cable to the new eye outlet because it was slightly different. It could cot clamp to the wires so I heated up the brass fitting and filled it to the top with hot solder and then dipped the cable with the exposed wires into it and waited for the solder to dry and harden. Everything has worked great but when I installed the battery, the light was still blinking? I took the battery back out and put it on the charger over night. This morning it said it was fully charged even though the Ultra 150 started up and ran just fine yesterday with where the battery was charged at. This morning, same thing. I installed the battery and even though everything is turned off, the warning light still blinks but now so does certain other things on my instrument panel but the battery is fully charged and the ski starts up just fine and runs fine but I am really perplexed as to why the light is blinking when nothing is on? I have an on/off switch that takes a key to turn everything on and then I hit my start button but when the key is turned to off, there should be no power to anything? Any suggestions would be much appreciated!
Thanks,
Jay
 

·
Registered
Joined
·
1 Posts
JayDawg,

Do you ever figure out what this issue was on your Ultra 150? I have a similar problem, where the JetSki tries to start as soon as I connect the Lanyard key. The ski is already on, but I never hit the green start button. It automatically tries to start. It only shuts off after I pull the lanyard key. The battery light is on and the warning light flashes.

Any suggestions?

johnnykujo
 

·
Premium Member
Joined
·
354 Posts
Discussion Starter #3
Never figured it out? But the ski's have been sittig the last 2 years. Youngest son had to have open heart surgery right after this post was made and then last year my wife was diagnosed with breast cancer. We plan on taking the ski's out for the first time in a few weeks and I will be re-charging the batteries soon so if it happens again, I will let you know.
 
1 - 3 of 3 Posts
Top