Personal Water Craft Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
any tips on undoeing engine mountings bolts that are slipping yam 650 marine jet.

:dunno:

i need to take the engine out but the first come out the second just spins with the rubber the third also. who designed these???

any tips stopping it spinning would be grateful. i downloaded the engine removal from this site which is really helpful but doesnt mention the mounts.:rolleyes:
 

·
Registered
Joined
·
323 Posts
That means the engine mount is broken. Youll have to replace it. Take the two bolts out that connect the mount to the hull. Once you have the engine out you will see it fall apart. Then you can grab onto the metal plate with vise grips and rattle gun it out. If you try to do it by hand, youll be there all year.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
oooer well i have at least two that are broken then. thanks for that, saves me wasting my time... i am a bit baffled on how to get the engine out. there is something on this forum but it states everything has to come off which i cant see to be the case?:confused:
 

·
Registered
Joined
·
323 Posts
Just take the exhaust off (not the manifold) and disconnect everything that you can see as long as you remember how to put it back in. are you only pulling the engine out to replace the mounts or is there an engine problem. Remember when you put new mounts in you will need to shim the motor again so the drive shafts dont vibrate and strip.
 
1 - 4 of 4 Posts
Top