Personal Water Craft Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
1 Posts
Help, new to the site and to the PWC adventure. My son has a 97 slt700 his uncle gave him. the rear piston is shot looks like something danced around the top. also how hard to eliminate oil injector? thanks to all :)
 

·
Registered
Joined
·
9 Posts
gag reads one bar when full of gas

I wanted to start a projects section and see if there is interest, anybody have something?
96 polaris 1050 xltx, just purchased and working out the kinks, problem the gas gage reads one bar when full of gas. have a parts ski and tried to remove the gas tank but not budging. any ideas how to remove the tank?
 

·
Registered
Joined
·
9 Posts
gas reads one bar when full of gas

I wanted to start a projects section and see if there is interest, anybody have something?
96 polaris 1050 xltx, just purchased and working out the kinks, problem the gas gage reads one bar when full of gas. have a parts ski and tried to remove the gas tank but not budging. any ideas how to remove the tank?
 

·
Registered
Joined
·
2 Posts
pllllease help !!!! polaris 140 breakdown

hi, my polaris 140 broke down a year ago and cannot find anyone who can fix it! or want to fix it as they dont like polaris. i know it must be a electrical problem telling the engine it is over heating, because it used to run for a while then just stop!! does anyone know who can re wire the computer?? or where i can send it. it needs someone to take it out because so many people think they have fixed it then when u are on it for a hour it breaks down. it needs someone to have abit of time with it, i dont care how long it take.... it is currently in majorca spain and i live in the uk..... please help!!!!! :(
 

·
Registered
Joined
·
3 Posts
I'm headed to go pick up my 96 polaris hurricane this weekend. After it being tied up in my divorce for over a year. I'll bring it home and head to the river to see if i can get it to run right. If not, i think I'll make it run faster during the rebuild. :)
 

·
Registered
Joined
·
3 Posts
Hi All, I recently purchased a 99 SLTX 1050 with approx. 60 hours on ithat has been sitting for a couple years and was running good prior to sitting. It was winterized and stored outside. The engine compartment was weather tight and looks good(hoses and such) and is clean. The engine also turns over good. What precautions and steps should be taken to get the engine and propulsion system ready for operation? Also does anyone have an extra seat for this model(red) or know where to get one at a reasonable price?

Thanks, Jeff
 

·
Registered
Joined
·
25 Posts
I've got a 93 slt 650 with no engine and am planning to put in a big water cooled sled engine,3 gal fuel tank (to reduce a lot of weight), and some nylon strips on the bottom to make a shallow river runner for my neighbor to use to check irrigation pivots. This would cut his 40 mile round trip to 4
 

·
Registered
Joined
·
7 Posts
Transplanted a '94 Sl 750 engine and pump into my 14' Polar Craft flat bottom. Gearing up to rip out the old interior and redo the decking and console.
 

·
Registered
Joined
·
1 Posts
We rebuilt the carburetor on our 2000 polaris jet ski. Everything was running good and after about 15 minutes it shut itself down and will not start now. We have checked the spark plug and battery and those are fine. Any suggestions on what could be our problem?
 

·
Registered
Joined
·
1 Posts
96 sltx no spark,help!

I purchased a 1996 Polaris sltx from a relative he had setting in his shed for 13yrs he got it after it was rolled over and never started to refurbish it, Any how I bought a SBT motor and replaced it then when i removed the cover on the stator to switch to the new engine turns out it sat with water for 13yrs also well i cleaned it up the best i could and what do ya know it ran.
I ran it several test runs about 4hrs total and lost spark so i thought must be the stator so that winter i bought a new SBT stator and upgraded CDI now this spring i replaced the stator and still no spark so i bought a new coil and wires, still no spark,so after reading in the forums i decided to buy a voltage regulator, still no spark the cdi is putting pulses to the coil but i'm at a stand still don't know where to go from here. Oh and i also bought a new kill / tether switch and tried that, Any idea's that anyone has would be very appreciated.
Boy finding new parts for a 21yr old machine is tricky lol.
 

·
Registered
Joined
·
1 Posts
Got a 2004 Polaris MSX 150 that runs high rpm out of water and no drive line connected... Also engine would not die with tether pulled or by holding stop button. SIFB bad? rev limiter works and 1-2 min time delay appears to work.
 

·
Premium Member
Joined
·
5,059 Posts
Got a 2004 Polaris MSX 150 that runs high rpm out of water and no drive line connected... Also engine would not die with tether pulled or by holding stop button. SIFB bad? rev limiter works and 1-2 min time delay appears to work.
You need to start a new thread in the Polaris forum if you wanting help.
 
1 - 16 of 16 Posts
Top