Personal Water Craft Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I bought a used 96 sea doo xp, ran one tank of gas through it, it ran great, ran out of gas on the lake had to tow it in. put brand new gas and oil the next day, was hard to start and would idle only, when i give it gas it dies. pulled the carbs cleaned everything, one of the filters in one of the carbs was clogged. now it will crank and idle but dies when i give it gas. seems to be getting to much gas. any suggestion? thanks
 

·
Registered
Joined
·
12 Posts
check fuel filters, fuels lines, make sure everything on tight, especially around the fuel baffle/sending unit. Take the breather off and look into the carbs while running, should be able to see if its getting gas...actually sounds like not enough gas to me.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
when i put my hand over the carb it gets gas on it, would it be benefical to put in new carb kits? when i cleaned the the floats moved easy, on diaphragm was a little loose. thanks for your suggestions
 

·
Registered
Joined
·
12 Posts
fbarnette said:
new carb kits in. still bogging down what should i look for next, what about the fuel pump. thanks


Check all the lines for blockage and cracks...blow through the lines, see if you can get the vaccum thing going...could be anything loose on the fuel sender, its lines, clamps etc...I thought I had faulty sender on an SPi...turned out clamp where the sender goes into the tank was just loose.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
after further digging it turns out it the brass gear on the rotary valve stripped, what are the odds of running out of gas and that happening at the same time, oh well it was not that hard to fix, thanks for the suggesitons.
 
1 - 7 of 7 Posts
Top