Personal Water Craft Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi!

I have a 1995 Yamaha WaveRunner III GP. It cavatates or revs up really bad when I take off going straight. However, if I turn a little to the right or left when accelerating it gets up on plane just fine. I took it in to have some work done and the guy said my impellar looks ok. What else could be causing this issue? Any Ideas?

Thanks for any info!! :)
 

·
Registered
Joined
·
2 Posts
I am having this same sort of issue with my 2000 GP1200r but others I know with the same Ski say they have always had it and think its normal, only does it from about 11mph to 20mph, once it gets going, and then she is fine. So its when your getting on the gas that it does it. The implellar on mine is newer, nothing wrong with it, but still does it.

Not sure if it truly is something normal on the GP1200r but would like to figure out just to make sure.
 

·
Registered
Joined
·
36 Posts
Something is obstructing flow to the impeller,or the leading edges of the impeller are damaged from rocks or other solid objects.When you turn on your ski you are slow the flow of water to the impeller.Hence the reason for it hooking up.Have you added any aftermarket intake grates of impellers?On my kawi it has fins behind the impeller and if your is the same you could of passed some sort of debris the is causing unwanted turbulance in the pump housing.Look into your pump housing from under the ski with a light to see if there is anything that could be giving you this trouble
 

·
Registered
Joined
·
47 Posts
cavitating

if there's no obstruction in the pump, then it might well be the wear ring, you might have to pull the pump out and get a good look at both the impeller and wear ring,. That would be a good time to upgrade to a better aftermarket impeller and intake grate.
 
1 - 4 of 4 Posts
Top