Personal Water Craft Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Has anyone had a problem with the EZ port jet ski lifts?
I’ve had problems for 2 years now getting mine off the lift.
I thought it was a problem with the rollers.
When I turned the Waverunner over today to clear a clogged intake I discovered these massive holes in the hull!

Th are are obviously factory cutouts to reach the engine mounting brackets but whatever Yamaha use to cover the holes was weak!

I also noticed the EZ port has changed the design of their lifts since 2015 so I think this must be a common problem?

I would appreciate any feedback.
 

Attachments

·
Registered
Joined
·
1,463 Posts
I don't see this being caused by the lift. I appears to me to be almost like the covers over the hole is rotting. Look at how the fiberglass layers have completely separated. It's not been broken. It's delaminated and falling apart. I would say piss poor glass to begin with and falling apart.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
That would be a Yamaha defect then as I bought it new.
From what I’m reading the hulls aren’t fiberglass but NanoXcell
 

·
Registered
Joined
·
1,463 Posts
Yes, depending on what year, can be nano cell. you don't mention ski yr, model. Yes it could be a defect in the hull. Doubt it would be covered at this point depending on the year and if there was a recall on them for this. May be worth a phone call though.
 

·
Registered
Joined
·
1 Posts
I have 2 of these EZ ports. They are 2005 vintage. I have replaced the rollers a few times due to the shafts bending and preventing the roller from rolling
I have a 2008 FX Cruiser SHO that works fine on the one. I have a 2013 FZS on the other and its a major pain to get off. No hull damage that I'm aware of
but now I will look this weekend.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #10
The shafts are bent on mine as well, they have changed the design on the new ports to not have the center rollers
 
1 - 10 of 10 Posts
Top