Personal Water Craft Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi, I have a pair of 08 fx sho's last time out the farther-in-law got stuck on a sand bank , before I had time to get to him he had been giving the ski gas to get the ski of the sand bank "so pulled lots of sand through the pump". Now the ski cavitates while getting on the plane , once on the plane it goes fine and has no power loss Just. not as quick getting on the plane.

Does this sound like impellor worn.

I am a competent motor mechanic and hope to try fix this myself anyones advice welcome

Thanks Dan
 

·
Registered
Joined
·
3,033 Posts
Yea it sounds like a pump problem. It is pretty easy to check. Use a feeler gauge to measure clearance between the impeller and wear ring. I'm not sure what the spec. is for the SHO, but someone on here probably has a service manual. On the older FX HOs it should be between 0.35-0.45mm. Check it at multiple points. Also look carefully at the impeller for dents, etc., that will reduce performance.
 

·
Registered
Joined
·
3,033 Posts
If the SHO is like the older FX HO models, there is really not a separate wear ring. Basically the wear ring is part of the impeller housing, so you have to replace the whole housing. Its not too big of a project, but you will need a tool to hold the drive shaft, etc.. Aftermarket housings are available which do have replacable plastic wear rings. Some guys recommend them if you ride in certain conditions where you will be constantly ruining the stainless steel lining in the OEM housing, but the plastic rings do tend to wear more quickly than the OEM SS housing.

 
1 - 4 of 4 Posts
Top