Personal Water Craft Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 2002 Polaris Genesis I with only 72 hours that I just bought. It is my first pwc so please pardon my ignorance. Yesterday I tried to start it and found the battery to be very weak and wouldnt take a charge, so I replaced it. After replacing the battery I tried to start it and when I did it turned over for probably 15 to 20 seconds without starting. I then pulled a plug wire to check for spark and it was firing good. thinking maybe it wasnt getting fuel, I poured a small amount of premix fuel in the carbs or throttle bodies and tried it again. WHen it finally started it ran for just a few seconds and then backfired so hard that it blew off the exhaust hose! I continued trying to start it and almost everytime it backfired. It backfired louder than any backfire I've ever heard. I put it back together as I didn't want to do any damage and thought I would try to research it and see if anyone else has had the same problem. Any thoughts/help would be greatly appreciated. Thanks
 

·
Registered
Joined
·
37 Posts
Generally speaking (?) a backfire like that is due to the ignition timing being WAY off - in other words, your fuel/air mixture is "exploding" at a time where it should not be. I don't know your machine, but something has slipped or ???.
 

·
Registered
Joined
·
9 Posts
You will need to check for error codes in the EMM/ECU. Doing this can help you determine what is causing the ski to backfire. If you need help getting the error codes let me know.
 

·
Registered
Joined
·
37 Posts
Hey trigly: Did hi-tech hit these skis in 2002 or what year??? I have a code reader for cars - what do you need to pull codes from a ski?? Could you please provide more info?
 
1 - 4 of 4 Posts
Top