Personal Water Craft Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I just bought a 1999 Ymamaha gp1200x. It has lost spark on the front cylinder. Any suggestions as to where to start looking?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3 (Edited)
Thanks JIT. I had already taken it back to the CDI. I unplugged the #1 and #2 coil and crossed them and checked for spark. It sparked. Put them back, and it is still sparking now. Put plugs back in -- no skipping. I thought great, but it is not quite right.

Idle is rough, boggs a bit on take-off. I have a 95 WaveRaider 700 that can outrun it (barely) in a 3/4 glass run. The 1200 should murder the 700. It starts porpoising and seems to cut out in the porpois thus accentuating the porpois. Any suggestions, or should it be a separate thread? By rough idle, I mean major vibration, not that the engine is trying to die. It is also vibrating badly at low speed. If it were not for the porpoising issue, I would think engine timing.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
JIT, I did some further diagnosing today. Would you tell me if this is still consistent w/ carbs on this ski. :

Compression check
1 = 105#, 2 = 110#, 3 = 111#
Is that good enough? Verified that oil pump is pumping by using flush kit after compression check w/ carb cover off - could see oil oozing into each cone from ports. Starts great, but major vibration at idle and at slow speed. Vibration is so bad, you cannot keep your hand on the carb cover. With RPM raised, it smooths out. I swear the engine is going to vibrate out of it. As for the gas - It took about 9 gallons to fill it up Saturday, and we used it for about 2 hours on new plugs. (I did set the gap to .024) I do not know how much gas we burned. But I guess w/ 2 hrs just trying it out.

If still carbs, could you recommend the part# (and possibly where) for the kit for all 3 carbs. I have found conflicting information online for kits and prices ranging from $47 to $176. 1999 GP1200X w/ minkuni bn44.

Incidentally, I picked this up at a bankruptcy sale. I got this ski running rough, a 2000 Kawasaki STX DI (locked up motor), a 95 Waverunner III w/ bad wear ring and impellor but motor runs great, 1 double trailer and 1 single trailer all for $1600. Did I do okay? I went from 1 to 4 PWC.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
JIT, I did some further diagnosing today. Would you tell me if this is still consistent w/ carbs on this ski. :

Compression check
1 = 105#, 2 = 110#, 3 = 111#
Is that good enough? Verified that oil pump is pumping by using flush kit after compression check w/ carb cover off - could see oil oozing into each cone from ports. Starts great, but major vibration at idle and at slow speed. Vibration is so bad, you cannot keep your hand on the carb cover. With RPM raised, it smooths out. I swear the engine is going to vibrate out of it. As for the gas - It took about 9 gallons to fill it up Saturday, and we used it for about 2 hours on new plugs. (I did set the gap to .024) I do not know how much gas we burned. But I guess w/ 2 hrs just trying it out.

If still carbs, could you recommend the part# (and possibly where) for the kit for all 3 carbs. I have found conflicting information online for kits and prices ranging from $47 to $176. 1999 GP1200X w/ minkuni bn44.

Incidentally, I picked this up at a bankruptcy sale. I got this ski running rough, a 2000 Kawasaki STX DI (locked up motor), a 95 Waverunner III w/ bad wear ring and impellor but motor runs great, 1 double trailer and 1 single trailer all for $1600. Did I do okay? I went from 1 to 4 PWC.
 

·
Registered
Joined
·
61 Posts
carbs

Sounds like your carbs need re-built badly. The bad vibration is most likely your idle adjustment. Reset all your screws and start from scratch. If you need directions for this I can post some info!
 
1 - 8 of 8 Posts
Top