Personal Water Craft Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi. Need your help. I just got a used GPR 1200 2001. The machine looks fantastic clean and ran on the hose when I purchased it.

I took it to the lake yesterday and could not get it to go above 33 mph. Got it back to shore. Changed filter (Gas) and replaced new sparkpulgs.

The Machine seems to start off but falls on its face as I increase speed.

Had it on the trailer and noticed that it backfired twice... once on trailer and once in water...

Any suggestions? No leak bielge... no oil anywhere... everything looks really clean...:dunno: Please help. This is my first machine.
 

·
Registered
Joined
·
2 Posts
I did the same thing when I bought mine. Got on the water and no top end. Had it looked at and ended up having to replace the fuel reads. hope that helps.
 

·
Registered
Joined
·
209 Posts
do a compression check...

definitly check your reed valves, if there chipped in the corners or not touching the cage than replace them...... get vf3's if you can afford it....if not just get more stock petals,,, carbontech suck..

also get waveeater clips for the powervalves,, this will prevent the pv pin from dropping into the jugs...

theres a number of other mandatory mods for any gpr ....search some of my posts its all in there....
 

·
Registered
Joined
·
4 Posts
Hi. Need your help. I just got a used GPR 1200 2001. The machine looks fantastic clean and ran on the hose when I purchased it.

I took it to the lake yesterday and could not get it to go above 33 mph. Got it back to shore. Changed filter (Gas) and replaced new sparkpulgs.

The Machine seems to start off but falls on its face as I increase speed.

Had it on the trailer and noticed that it backfired twice... once on trailer and once in water...

Any suggestions? No leak bielge... no oil anywhere... everything looks really clean...:dunno: Please help. This is my first machine.
Simmilar thing happend to me... About 2 months ago, I bought a 2000 GP 1200 R with some hours on it... My 1st PWC as well...

The guy was seemingly honest and told me it didn't seem to be running right and he did not want to put any time or money into it... He said he thought that it had the catalytic converter removed and D plate put on and it was going to need either some carbs replaced or atleast worked on...
We went to the local power sports joint, picked up ahand full of sparkplugs, a Dplate and gaskets, a new diapghram (clear plastic looking thing) and a few gaskets for the carbs...

My buddy, then took the three carbs off and went though them cleaning them out... There were three little filters that were all between 90 and 100% clogged...
He cleaned them, put everything back, ran it for a few changed the plugs and shes been purring since...
 
1 - 6 of 6 Posts
Top