Personal Water Craft Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1 (Edited)
So my 88 kawi 550 started fine this morning then after riding a little bit i cut it off and rested. when i went to start it-- nothin. opened it up and put more fuel in it. now it won't start. it seems like it's not getting fuel through the tube. is there a pump on this ski? when i spray starter fluid in the carb it tries to start but i can see that there's no fuel in the inline filter going through the tube to the carb. when you try to start it with carb fluid multiple times it seems to pull fuel into the carb. we got it started that way by trying to start it with carb fluid multiple times (like 20x+) and the filter was full of fuel and then it started up and ran fine until it was cut off again and left sitting there.
is the fuel system pumped into the carb by vacuum? there is an aftermarket bigger gas tank and the cap that holds the tubes isn't completely sealed. maybe that's the issue?

btw it's a stand up if that helps anything? oh and before we were having the fuel issue it didn't want to try to start so we started to charge it, the clicking was coming from the electrical box. maybe it got some water in and it shorted something for the fuel pump, if it has one.
 

·
Registered
Joined
·
88 Posts
So my 88 kawi 550 started fine this morning then after riding a little bit i cut it off and rested. when i went to start it-- nothin. opened it up and put more fuel in it. now it won't start. it seems like it's not getting fuel through the tube. is there a pump on this ski? when i spray starter fluid in the carb it tries to start but i can see that there's no fuel in the inline filter going through the tube to the carb. when you try to start it with carb fluid multiple times it seems to pull fuel into the carb. we got it started that way by trying to start it with carb fluid multiple times (like 20x+) and the filter was full of fuel and then it started up and ran fine until it was cut off again and left sitting there.
is the fuel system pumped into the carb by vacuum? there is an aftermarket bigger gas tank and the cap that holds the tubes isn't completely sealed. maybe that's the issue?

btw it's a stand up if that helps anything? oh and before we were having the fuel issue it didn't want to try to start so we started to charge it, the clicking was coming from the electrical box. maybe it got some water in and it shorted something for the fuel pump, if it has one.

The fuel pump is in the carb, the BN44 has a round body facing the right side of the ski. This is the fuel pump, it works from +/- crankcase pulses. Sounds like a rebuild kit is in order (approx $40). The tank need to be completely sealed. There is a one way check valve (white plastic device) located right above where the fuel and return lines go in and out of the tank. This device allows pressure into the tank from outside ambient pressure and heat, however will not allow it out. The tank need this pressure to assist the fuel pump.
 
1 - 2 of 2 Posts
Top