Personal Water Craft Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Please help, like an idiot i left my drain plugs open on my seadoo xp (99'). I noticed it after being in the water about 5 minutes. I pull the ski out of the water with the plugs open to drain out the water because the ski would not start. I drained all the water out. NOW WHEN I GO TO CRANK the ski ,I DO NOT GET A CRANK OR A CLICK. I GET LIKE WIERD NOISE, as if the starter is not kicking in and something is just rotating. This is probably the weirdest case you guys have ever heard but i do not get a crank nor a click. PLEASE HELP ME!!!!
 

·
Registered
Joined
·
11 Posts
Was the sea doo running with the plugs out as it was filling up with water? DO NOT TRY TO START THIS AGAIN until you find the problem! If there is water in the engine it could blow!
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Spark plugs were in ofcourse, and drain plugs were out but it wasnt running it was just shut off. I was waiting for my freinds to put their skiis in the water using a davit. I started sinking and then realized something was obviously wrong. I tried to crank but it wasn't cranking (i know that if water gets in you are suppose to drive out) so i pulled it back out the water and drained the water. This happened to me once before but atleast i would get a crank but it just wouldnt start. But now i am not even getting a crank and i am not getting a click, i just get some wierd "eeeeeeeeennnnneee" sound. I am affraid that i have really done damage to it.
 

·
Registered
Joined
·
11 Posts
Ok you may have gotten water in your electrical box. Check to see if there is water in there because if the starter solenoid got wet it could have gotten fried thus not working. Also grab a pair of vice grips or big pliers and get a hold of the drive shaft and try and turn it in either direction. Let me know how it goes.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
That sounds like it could be it. Its like if something is turning in there but its not the motor. I know that sounds weird but i am trying to explain it. I should of probably started the thread by mentioning that I am not really mechanical savy so i dont really know what you are talking about when you mention crank shafts or electrical boxes but i do have a owners manual so i will find it tomorrow. THe electrical box is the the one with about 6 connecter plugs going into it, correct? The crank shaft i wouldnt know squat about but i will try to look in the manual. Thank you very much though i appreciate it.
 

·
Registered
Joined
·
11 Posts
um generally the box I am talking about will have one plug on the top of it and will have a solenoid inside of the box (I am not 100% sure about your specific model check your manual for the location). And as for the drive shaft, it is the shaft that comes out of your engine to the impeller and it is what turns the impeller. There is probably a plastic cover over it being held on with two plastic wing nuts. Take this off and grab the drive shaft with a vice grip of pliers and try and turn it in either direction. And also check to make sure your battery is charged.
 
1 - 8 of 8 Posts
Top