Personal Water Craft Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited)
Hey all I hope that someone can help me out. I recently purchased a 1995 SEA DOO XP 720 and for some reason it will turn on when a hose is running water thru it but not when I put it into the lake. When I try to get it going in the water it will shut off as soon as i let go of the throttle. It has a brand new battery and new spark plugs! any help with my situation will be greatly appreciated... Also the jet ski is running a mix so the oil is not set up its only running on the fuel tank pre-mix..
 

·
Registered
Joined
·
23 Posts
Sooo...

Your saying that sitting in your driveway hooked up with a hose(pressurized cooling system)..that the ski starts, idles and revs with no problems..

And when sitting in the water(no pressure through cooling system) it dies when you release the throttle..

I would suspect two things..

First. there may be some kind of pressure switch in your cooling system that shuts the igntion down when it senses a loss in pressure(from blockage or water pump failure, etc..) of the cooling system..

Secondly, you may be looking at a waterpump that is failing but hasn't completely yet..

Not a lot else explains what you are describing..

Hope this helps..

Brian
 

·
Registered
Joined
·
227 Posts
Please don't listen to tymeshare. There is no water pump, only pressurized water from the jet pump to go up to the motor. Look at the top clear hoses out of the head and headpipe to see if water is coming out. These are called the csi, cooling system indicators, and they show that your cooling system is clean or plugged. No switch other than a temp sensor in the head either. Machine might have low compression, no oil getting into the motr, low idle, mis-adjusted carbs. Idle should be 3000 rpms out of water and 1500 in the water. Adjust you idle stop screw to this setting.
 
1 - 4 of 4 Posts
Top