Personal Water Craft Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey everyone. I have a 97 kaw 900stx
Havin a cavitation problem. Had the impeller remanned and trouble still here. Does anyone have a manual and can check what the clearance limits are from the edge of the impeller to the pump housing?
Also another question.
My trim seal around the pump housing is lookin a little worn down on the sides. Would this cause a cavitation problem also? Any help is appreciated.:dunno:
 

·
Registered
Joined
·
3 Posts
Hey everyone. I have a 97 kaw 900stx
Havin a cavitation problem. Had the impeller remanned and trouble still here. Does anyone have a manual and can check what the clearance limits are from the edge of the impeller to the pump housing?
Also another question.
My trim seal around the pump housing is lookin a little worn down on the sides. Would this cause a cavitation problem also? Any help is appreciated.:dunno:

Hey I think I am having a problem similar to yours I installed a stainless steel impeller and I think I have a cavitation problem, my seal is also worn, Have you found out anymore info about yours if it is or not.
Thanks
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
I have found that the clearance shouldnt be more than .6mm
Mine is in specs. I took the pump out and resealed everything. Now im just waiting for the weather to break here so I can test it again. The only other alternative I could think thats causing it would be a leak in the bearing holder on the hull. The one the driveshaft goes through. Could be sucking air from there but not sure how to check for it. Any luck with yours yet?
 
1 - 3 of 3 Posts
Top