Personal Water Craft Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
My friend just got a 550 with a pipe and water box. It will start but it backfires and will not rev up. it has 120 psi on both cylinders new plugs and gas. I took the timing cover off and when it runs, barely, the timing light shows the pointer between the two marks, but i cant check total advance. the carb looked clean when i took it apart, but im gonna throw another one on tomorrow. When i check the timing the pointer was between the marks when the timing light was hooked up to the rear cylinder, the one closer to the pump. is that the cylinder you check? Any ideas on why its backfiring? I tried to pull the flywheel but i was unable to even when using an impact wrench. i read somewhere that these are prone to have a failure with the woodruf key, how hard is it to pull off the flywheel usually? any help is appreciated, thanks.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #3 ·
I was using a harmonic balacer puller but it wasn't coming off, until someone had the bright idea to hit it with a hammer. so i got the fly wheel off. the stator looked good, there was a notch on it with lined up with part of the case, so i assumed the timing hadn't changed. I switched the plug wires to the opposite cylinder and the ski runs exactly the same, doesn't rev, and backfires. very rarley it will build a couple r's but will immediatley fall off and continue with a rough idle, Im thinking its something with the ignition. any ideas as what could be bad, i have a good spark and the cdi box is clean.
 
1 - 3 of 3 Posts
Top