Personal Water Craft Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
This one sat for two years til I bought it tonight. Starter fluid got it running and it idles now. But I fear the injection isn't working because there's no smoke.

Any other "Must Do's' with this old piece of fun?

Check the gear oil?

Thanks!

-Michael
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
> you sure it is still injected?

No. Good point. The line does run from the oil tank to the carb. It looks VERY clear though. I'm surprised the oil is so clear. It's probably OK after two years - yes?

> the gear oil is in the jet pump

OK, so that's separate from the injection oil. I'll search for an inlet to check it.

Thanks VERY much.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
Seems to go to the base of the carb. Can you think of a way to test whether oil is being injected? I fear I'll burn it up testing it.

I mean, it should smoke like a regular two stroke, right?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
It smokes it smokes! :appl: Just ran it longer with a hose on the rinse system.


But BOY does it clatter. Hope that's normal. :dunno:
 

·
Registered
Joined
·
8 Posts
Discussion Starter #8
Great question.. I'll give it another listen and use the ol' screwdriver to the ear trick to figure where it's coming from.
 

·
Registered
Joined
·
6 Posts
Don't mean to jack this thread, but is there an easy way to remove the oil injection on these. I just picked up a 85 JS 550 and an older sea-doo (90?). I just want to run premix in the sea-doo. I don't trust the oil injection and have no idea what condition it is in.

Thanks,
Matt
 
1 - 9 of 9 Posts
Top