Personal Water Craft Forum banner
1 - 5 of 5 Posts

·
Premium Member
Joined
·
354 Posts
Stupid question but what did your old spark plugs look like when you pulled them out? Also, check your lines and make sure you have no water in your fuel or that there is no fuel or vacuum leaks any where.
 

·
Premium Member
Joined
·
354 Posts
They had grey/brown stuff all over the sparking area. They are the third set I have put it in two weeks. I did put lower grade mixing oil in the fuel
I am familiar with your model of stand up ski but I do not remember, do you have to premix the oil or is it injected? That could also be a factor is a bad mix or your oil injection could be malfunctioning.
 

·
Premium Member
Joined
·
354 Posts
Since you have a 2 stroke motor, you should have exhaust coming out of it. You should see my Ultra 150 when it is running out of the water. It smokes bad. My 750 SXI is not as bad but seeing the exhaust come out is normal.

Is your ski starting up now?
 

·
Premium Member
Joined
·
354 Posts
I'm wondering if it isn't your electrical box that box of your spark plugs go to. Mine did something very similar several years ago after I sunk it at the river. I refloated the ski but had to replace my electrical box. Fortunately, the ski was still under warranty and everything was covered. Take the spark plugs out of the engine but leave them connected to the plug wires and turn over your motor and see if there is any spark. Then let me know what you find.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top