Personal Water Craft Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi, '91 sc. motor continues to run when either (or both) the engine off button is pressed and the lanyard is removed. I checked the switches and they are fine. Checked all wiring down to the electrical box, fine. In the electrical box, there is a black ground wire from the 2 kill switches but it looks like it goes into the cdi . Please confirm where this wire goes and if it does go into the cdi, do I have to get a new cdi to get the thing to shut off? Thanks
 

·
Read Only
Joined
·
5,059 Posts
There is a grounding point in the box, I believe it is by the cdi box and rectifier and that's actually where that ground should terminate. Parts diagram shows appx 3 grounds on that bolt. Going off other diagrams, the white wire goes straight to the cdi. The button grounds the white to kill the engine.
Just for shits and giggles, I would pull the stop button apart and clean the contacts. It is extremely common for them to corrode.
I would also check continuity from the bolt head to the contact inside the button.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Thanks for response. the black and white wires from the switches definately go into the cdi. A black wire comes out of the cdi and joins 3 other black wires from other places on the rectifier bolts. Would the black wire that comes out of the cdi be the end of the line for the one from the switches that went in?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
additional info: cleaned all of the previously mentioned ground wires and connections, no change. ski keeps running. When I unplug the white and black wires from the switches at the connector before the cdi and put an ohm meter across them and push the buttons, I get an increase in the ohms which I assume means the switches are activating. thanks
 

·
Read Only
Joined
·
5,059 Posts
All the stop button is doing is grounding the white wire. If you take a piece of wire, attach it to a good engine ground, touch it to the white wire, it should kill the engine.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
Thanks for help. I grounded the white wire at the plug going into the cdi. It did kill the engine. Once I did that, the buttons started working again. Don't quite understand why, but all good now.
 
1 - 6 of 6 Posts
Top