Personal Water Craft Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
163 Posts
Did you check your Rotary Valve when you did the rebuild? Sounds like it could be damaged, mis-adjusted, or the clearance could be too great ie. worn out.
 

·
Registered
Joined
·
163 Posts
Reving out of water doesn't mean as much as you'd think since there's no load on the engine.

Why did you rebuild the topend?
 

·
Registered
Joined
·
163 Posts
mhillis said:
Ok, so I replaced the fuel pump, and checked the fuel and oil filters (both are as clean as new). But there is still a problem. When the ski is out of the water, with the flush system onit, it revs and sounds strong, but when it is in the waternothing, the ski barely moves in the water:mad: . Any ideas?

OK, so I just noticed your second post...

Have you rebuilt the carb yet? If not, that's probably whats wrong.
 

·
Registered
Joined
·
163 Posts
An out of spec RV can cause the symptoms you're having, but it could also be a really poorly tuned carb... I was asking why you rebuilt the topend because that would help me know if there's any possible damage to the rotary valve.

And you can determine TDC the ******* way by using a pencil in the cylinder through the sparkplug whole. Rotate the crank until the pencil reaches it's apex, where it stops going up and before it starts coming down. That's TDC.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top