Personal Water Craft Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Basically, it has a balance problem. When I'm cruising at about 30 mph or higher, if I try to ride a straight line the jetski starts trying to lay over on its right side. I have to make turns to the left to keep from tipping. If I want to ride a straight line, by slightly turning to the left I can keep it balanced, but the jetski is riding slightly sideways.

Also, when I turn a tight circle to the right, it is difficult to come out of it without tipping.

These are brand new, I'm very concerned because the dealer is attributing it to weight sensitivity, but it doesn't matter where I shift my weight, it keeps wanting to lay over on its right side.

Do these things have alignments? What can I do? I'll be paying for these things for 6 years, and I don't feel they are safe to ride.

If anyone has any insight, please feel free to reply or contact me.

Rich.
 

·
Registered
Joined
·
2 Posts
It may just feel that way - if you feel like you are tipping, give it a little gas and you'll be OK. I have two R12X's and I have some stability issues at 5- 10 mph, but not unlike any other ski!!

T
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
It may just feel that way - if you feel like you are tipping, give it a little gas and you'll be OK. I have two R12X's and I have some stability issues at 5- 10 mph, but not unlike any other ski!!

T
Thanks for your reply. The reason I am concerned is that the problem has gotten progressively worse. I noticed it a little at the beginning of the day the last time, but by the end of the day it had become a big problem. It really feels like it is not calibrated right.
 

·
Registered
Joined
·
4 Posts
You may want to inspect your impeller really closely. I had the same problem along with a vibration while accelerating on my F12. Upon inspection I found a flat piece of shell (oyster or something similar) jammed in the intake side of one of the impeller blades between the blade and the housing. It was causing friction on one of the three blades. If you are only having the problem on one of the skis it may be the problem. I never had a balance issue other than that.

Worth a try.
 
1 - 4 of 4 Posts
Top