Personal Water Craft Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 2005 R-12x turbo that now has a whining noise after winter rest.

Cranks, runs fine otherwise. Anyone know what causes this?

Thanks, jcd
 

·
Registered
Joined
·
18 Posts
I have about 60. I bought two at the same time used from fresh water. The other one actually has about 80 hours and is quite. I took out the bearing tube, jet pump coupler etc. and inspected. I couldn't see a problem with any of my seals or bearings.... all are clean and tight. I repacked the bearing with fresh grease, However when I put it back together I took it on a 50 mile ride and it was whining again when I took it out of the water???? Doesn't seem to be getting louder, just louder than the other ski. I think the noise is coming from the jet pump. I have good clearance on the impeller. May just keep riding and pay attention to see if it worsens?
 

·
Registered
Joined
·
18 Posts
I should clarify. I didn't disassemble the pump, just the cone. I don't have the impeller wrench. When I spin it out of the ski, it makes a very slight noise... I'm sure at a higher rpm it would cause a whine. Do you think I have a bad/going bearing and bad seal behind the impeller I cant see?
 

·
Registered
Joined
·
20 Posts
What type oil are you using? I have heard some say the noise is lower when you use a synthetic or a different weight. My ski has about 22 hours and I went to synthetic this past spring.
 

·
Registered
Joined
·
18 Posts
That's what I'm guessing as well. Did you change it yourself? I just ordered an impeller wrench and am waiting for it to arrive. I don't believe the bearings/seals are pressed in. If not it shouldn't be too tough.
 

·
Registered
Joined
·
4 Posts
nope..... took it in. and fromwhat i have heard, they are a pressed on bearing. make sure to order new water seals... i would think change both bearings while you are there...

i am a newbie... so didnt want to take any chances.
 

·
Registered
Joined
·
18 Posts
ordered all of the parts including the shaft for about $130. I am going to press the bearings and seals in myself to save the labor. With that being said I have ridden it for about 140 miles and the noise isn't getting any worse. I will let you know how hard the project is in a week or two.
 

·
Registered
Joined
·
285 Posts
Mine has a grease zert towards the back I squirt it with a couple of pumps from the grease gun after every ride, may want to try, it forces out the water and doesn't let it sit in water during the week when i'm not ridding it.
 

·
Registered
Joined
·
18 Posts
Yeah, I was told some people tap a fitting into the cap to do that. Did you put it in or was it there when you bought it? Also can you reach the fitting without taking the nozzle off?
 

·
Registered
Joined
·
285 Posts
mine was already their if i pull the back seat it sits way to the back and you can follow the hose down to the bearing, check and make sure you might already have it and its just laying loose in the bottom of the hull. Not sure if you can drill it and tap to put one it tought? Have to look at a parts break down and see, but i would think its already their, down by the black shroud just off the back of the motor.
 

·
Registered
Joined
·
18 Posts
Yeah, mine has that as well. The bearings that the thread is talking about is the ones in the pump housing. apparently the front seal behind the impeller leaks after a while and makes the bearing start whining.
 

·
Registered
Joined
·
18 Posts
Just an update. I received my parts after waiting a couple of weeks. Pressed them in myself using a press at my brother's work. Took it out and rode it 45 miles. Beautiful! Sounds like a brand new ski. Thanks everyone.
 

·
Registered
Joined
·
2 Posts
PHP:
Just an update. I received my parts after waiting a couple of weeks. Pressed them in myself using a press at my brother's work. Took it out and rode it 45 miles. Beautiful! Sounds like a brand new ski. Thanks everyone.

I have a couple 04 R-12s, one of them is doing the same thing. Did you buy a pump rebuild kit? Where to purchase it? Can you buy a wrench for the impeller at a local parts store? Did you have to buy a new shaft?

Thanks
 

·
Registered
Joined
·
18 Posts
You can buy the kit at SBT (Short block technologies) for around 60-65. I bought the wrench on e-bay for about 10-15 and I replaced the shaft although it was fine. I replaced it anyway. The biggest part is having access to a press with plenty of pushers for the correct sizes. Also you will want to read a manual to make sure you know how it comes apart since there are a series of snap clips and the assembly is pretty specific as to how to take it apart and put it back together. I'm not telling you this to discourage you from doing it yourself. If you have/know these few things, it's only about 1.5 hour job and can save you a few hundred bucks. Last note, if the noise just started you can probably ride it for a long time that way, just keep clean grease in it. The assembly is ball bearings and they are tough! The noise is simply surface corrosion on the bearings from a bad seal. Mine was making the noise when I bought it and I rode it for about 200 miles before I replaced them.. the noise didn't get any worse it just irritated me. Good luck.
 
1 - 20 of 21 Posts
Top