Personal Water Craft Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
hello everybody. I bought my jetski a month ago. its 2006 with 148 hrs. I rode on it few times and everything was good until last week . when I ride it feels like the engine is choking on the full throttle it slows down and doesnt go faster than 45mph . when I ride and release the throttle is shuts off. even to start it I need to hold the gas . what could be the problem?? thanks
 

·
Registered
Joined
·
16 Posts
hello everybody. I bought my jetski a month ago. its 2006 with 148 hrs. I rode on it few times and everything was good until last week . when I ride it feels like the engine is choking on the full throttle it slows down and doesnt go faster than 45mph . when I ride and release the throttle is shuts off. even to start it I need to hold the gas . what could be the problem?? thanks
I had this problem myself. Found that I didn't plug the flush hose line before taking it out. Ended up flooding the engine compartment. Probably not your problem, but similar symptoms. Drained the engine compartment, plugged 'er up, headed out, everything was fine after that.
 

·
Registered
Joined
·
10 Posts
Could be spark plugs fouled, Is the dash working? I have seen this happen if the dash stops working or is damaged. engine oil level good? possible exhaust leak. also could be in slow mode. Hope some of this info helps
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
I got it fixed. I had exhaust leak . One hose got replaced and spark plugs and now everything works. thanks
 
1 - 5 of 5 Posts
Top