Personal Water Craft Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I'm brand new to pwc's.bought a 99tigerskark ts770l. First time out the power was very weakafter10minutes. The engine compartment was filling up with water.obviously the bilge pump want working.after I got it home and ran it with the hose the exhaust was dripping water and it appears to be leaking water from a flange on what I am guessing is the exhaust manifold to some sort of expansion chamber.this can't be normal but I know very little of engines.any thoughts?
 

·
Registered
Joined
·
15 Posts
That is exactly the same problem I'm having with my TS640L and I'm trying to find out how to fix the flange on the exhaust manifold and I'm also trying to find the fuse for the bilge pump too.

Did you ever get your issue resolved?
 

·
Registered
Joined
·
157 Posts
GPguy go to autozone or any autoparts and get some do it your self gasket paper and copy your old gasket and make your self your own gasket also with the paper you can make any other gasket for your motor and also apply some black rtv silicone to the motor or exhoust and let it become tackey so when you put the exhoust back on it wont fall off then put your bolts back on with some new lock washers.

shanep75 the fuse should be on the cover of your relay box where all your wires go to plus it can also be your relay.
 

·
Registered
Joined
·
15 Posts
I need to somehow figure out how to reattach the fitting on the top of the exhaust elbow though. It's the one that takes the hot water from the exhaust and sends it out the side of the machine. I'm wondering if I might be able to somehow remove it and thread some sort of a brass fitting in its place. Don't know if that would work. I may see how much the whole part is as it all comes as one piece I assume.
 
1 - 4 of 4 Posts
Top