Personal Water Craft Forum banner

21 - 35 of 35 Posts

·
Registered
Joined
·
3 Posts
I had the drivers seat redone when I got the boat and at the same time had the front and middle seats made up. The front is held on by velcro only but the middle has a row of push studs as well. The velcro is about 2 inch wide and really does hold them on nicely but still makes them easy to romve.

My stearing is a little tight move going full tilt. I always assumed that it was because you are trying to force the bucket against all that water hammering out. At low speed its OK. But when you close the lid it does seem to pinch on the cable. Could you please show me a photo of how yours is run.

Does your one have a small wind screen on it? I have holes where some sort of wind screen was once attached but have never seen one.
I also have the windscreen holes and no windscreen. Initially I looked into having one custom made from clear plastic, but I think a cheaper alternative may be to adapt a universal motorcycle windscreen, which often has simple bolt on mounting points.
 

·
Registered
Joined
·
9 Posts
BTW the GP760 pipe did not fit. I used a Raider 701 62t pipe and it just fits. I used the 144mm pump and jet nozzle (required some tig welding for retaining the reverse) from the GP but bought a new wear ring and a Hooker impeller from Impros. I also modified the steering nozzle for better flow. I used a WR3 aftermarket intake grate and upgraded the pto/shaft drive hub to the larger style with 5 fingers and bigger bearing.
The muffler is from the 701 raider and is located in the rear now.
I also added a Raider hood latch.
I put a total of $3k or so into this thing but after selling off the unused parts including the original 650 engine and the remaining donor ski parts I believe I at least broke even.
I will post some detailed pictures soon.
Projet420, post a few pics of yours.
Still hanging to see those pictures and vids!!!!!!
 

·
Registered
Joined
·
6 Posts
great thread - just picked up a 1991 projet last month. Having problems with the air chamber separating from the hull on rear port side which I will address in the spring when the weather warms up again. looks like a fun little boat.
 

·
Registered
Joined
·
6 Posts
PS: I'm near Annapolis MD.........there is a place here that sells the two part glue for inflatables, hopefully that will fix the separation problem. The RIB section of the hull has a groove in it like you would find on a sailboat mast for the sail to slide in. Then there is a T shaped flange that is glued to the side of the air chamber which has what in sailing you would call the luff rope in it (at the base of the T).top of the T glues to the chamber and the luff rope is fed into the groove in the hull. I'll post pics when I get a chance.........
 

·
Registered
Joined
·
9 Posts
PS: I'm near Annapolis MD.........there is a place here that sells the two part glue for inflatables, hopefully that will fix the separation problem. The RIB section of the hull has a groove in it like you would find on a sailboat mast for the sail to slide in. Then there is a T shaped flange that is glued to the side of the air chamber which has what in sailing you would call the luff rope in it (at the base of the T).top of the T glues to the chamber and the luff rope is fed into the groove in the hull. I'll post pics when I get a chance.........
Welcome aboard mate,

I just had my entire bolt rope/attaching rope reglued as it had started to let go in a few places. I leave all the glueing or repairs on the tubes to the professionals as if you dont get it right it can be an ongoing problem. My tubes where a bit tight to get off the first time but are fine now. Give the channels a good blast out with the hose when the tubes are off to clear out any crap. Good to here there is another 'Series 1' Projet out there.
 

·
Registered
Joined
·
6 Posts
Gluing Tube

Welcome aboard mate,

I just had my entire bolt rope/attaching rope reglued as it had started to let go in a few places. I leave all the glueing or repairs on the tubes to the professionals as if you dont get it right it can be an ongoing problem. My tubes where a bit tight to get off the first time but are fine now. Give the channels a good blast out with the hose when the tubes are off to clear out any crap. Good to here there is another 'Series 1' Projet out there.
Good advice.........Met a guy recently who had a fairly new Zodiac and had complete tube to RIB glue failure...he and his wife were motoring along when the glue holding the bolt rope failed.........fiberglass bottom section along with outboard sunk to the bottom.......they were left hanging onto the tubes.......
 

·
Registered
Joined
·
3 Posts
Hello,

I just bought a 1994 Pro Jet and it is in terrible shape cosmetically (a lot of stains and something that looks like rust around the decals)

what would you recommend for cleaning the pontoons?

thank you
 

·
Premium Member
Joined
·
5,059 Posts
Not familiar at all with this boat, but here are some things to look at.
Under no circumstance use any kind of solvents like MEK, or Toluene and the such. I have read that a 1:3 ratio of bleach or a Mr Clean Magic Eraser can be used if necessary, but not on a regular basis.
Might try some Simple Green.

Inflatable Boat Cleaning & Finishing Guide | Polymarine Paints, Adhesives, Parts & Accessories

https://www.auroramarine.com/store/speed-clean.html

https://www.bing.com/search?q=how+t...smsn=1&refig=f646ccbd6f1842b6b63618989bff9b59
 

·
Registered
Joined
·
3 Posts
Not familiar at all with this boat, but here are some things to look at.
Under no circumstance use any kind of solvents like MEK, or Toluene and the such. I have read that a 1:3 ratio of bleach or a Mr Clean Magic Eraser can be used if necessary, but not on a regular basis.
Might try some Simple Green.


Sorry for the late reply, and thank you for your suggestions.. will get to cleaning it this weekend. will post pictures most likely
 

·
Registered
Joined
·
1 Posts
Projet 420 tubes

Hello I may be a little too late but I also have a Projet 420 and I need to re-tube mine. Does anyone have any idea where I can get a set of tubes?



Thanks O. Maytin
 

·
Registered
Joined
·
1 Posts
BTW the GP760 pipe did not fit. I used a Raider 701 62t pipe and it just fits. I used the 144mm pump and jet nozzle (required some tig welding for retaining the reverse) from the GP but bought a new wear ring and a Hooker impeller from Impros. I also modified the steering nozzle for better flow. I used a WR3 aftermarket intake grate and upgraded the pto/shaft drive hub to the larger style with 5 fingers and bigger bearing.
The muffler is from the 701 raider and is located in the rear now.
I also added a Raider hood latch.
I put a total of $3k or so into this thing but after selling off the unused parts including the original 650 engine and the remaining donor ski parts I believe I at least broke even.
I will post some detailed pictures soon.
Projet420, post a few pics of yours.
Hello I have same setup currently on Project. I have had a lot of backfiring in mid-range. Been running at for a little while but getting tired of it I'm wondering what pitch prop did you use?
 
21 - 35 of 35 Posts
Top