Personal Water Craft Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I am new to jet ski's, but I've restored several boats. I just bought a 1993 750ss, it doesn't have any spark. I've been told that the stator has been checked and checked ok. I'm thinking it's the coil, I should know more by this weekend. Is there any good advice I should know for a new jet ski owner. Thanks for any advice.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Yes the lanyard is attached. I'm also thinking that this engine is not factory. I would have expected to see an oil injection system, and I can't find one anywhere. I do have the shop manual and it's not where it says it should be, is it fairly normal for someone to do this. It's got a BCW Racing Head on the engine. I'm just hoping that it's not the stator.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
I've checked the igintion coil and I'm getting 1 ohm on the primary and 15k ohm on the secondary. the 1 ohm is close but not within tolerance, but the seconday isn't even close. So I'm going to trim the plug wires and recheck.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Ok, one more question for ya 550, do you have the procedures for checking the stator. I'm thinking that's where the problem is. I have a manual but I can't seem to find a procedure for it.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
Ok, took the stator out and ohmed what I thought I could, and it looks good. basically looked for nearly a short. Then I checked the regulator/rectifier, should read no more than 30k ohms between two of the wires and I was reading 2.5M ohms....big difference. I'm checking on getting another one of these and I'll update. Actually I'm thinking about getting a complete E-box from ebay, but we'll see.
 
1 - 8 of 8 Posts
Top