Personal Water Craft Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I just bought an 07 Ultra 250X with 80 hours last week. Put it in the water for the 1st time over the weekend and it didn't run to the redline. It pulled hard and has very good acceleration but barely pulled away from an 8 year old Yamaha with 140HP. At top speed it was maybe 2 or 3 MPH faster. I was going around 54 MPH. At about 6750 RPMs the ski lurched and hiccupped. The boost seemed to stay right at 10 pounds. It was almost as if it had a rev limiter. It just floats around 6750 RPMs and flutters around there. How do I get the missing 1000 RPMs? The original owner says 7000 RPMs is the redline and that's how its supposed to be but I don't think so! I'll change the plugs and see what that does. Any help?
 

·
Registered
Joined
·
811 Posts
I just bought an 07 Ultra 250X with 80 hours last week. Put it in the water for the 1st time over the weekend and it didn't run to the redline. It pulled hard and has very good acceleration but barely pulled away from an 8 year old Yamaha with 140HP. At top speed it was maybe 2 or 3 MPH faster. I was going around 54 MPH. At about 6750 RPMs the ski lurched and hiccupped. The boost seemed to stay right at 10 pounds. It was almost as if it had a rev limiter. It just floats around 6750 RPMs and flutters around there. How do I get the missing 1000 RPMs? The original owner says 7000 RPMs is the redline and that's how its supposed to be but I don't think so! I'll change the plugs and see what that does. Any help?
Well dude, I think you were misled by the seller of your ski. You are right when you say it's off by 1000 rpms. You are surely leaving a 1000 rpms and about ten miles an hour on the table. It sounds like the guy that sold it is a newb. All of my skis rev out between 8100 and 8350 rpms As far as a fix for it, make sure the ski is not in the learning mode(ECU cuts power and rpms), have a dealer check it with a programmer for any error codes. I also know that the 07 ultra 250 had motor issues from plain blowing up to rough running. Good Luck

SEE YA :dunno:
 
1 - 2 of 2 Posts
Top