Personal Water Craft Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Bought an Ultra 250x with 85 hrs on it. Original owner and well maintained. Kept covered in a garage aside from a few months a year. Starts and runs fine but only goes about 35 under a load. Mechanic told the guy the supercharger was bad but I don’t think it’s been physically inspected inside. Doesn’t make any strange sounds. I only paid 2k so even I’m fine with investing a couple more thousand in it. Seems like low hours to lose a supercharger on a ski in this condition. Any thought or ideas are appreciated...
 

·
Super Moderator
Joined
·
5,057 Posts
Might find a copy of the manual. Superchargers need regular rebuilds around 100hrs. Could also be the belt from what I've read. What rpm is it running at that speed ?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Might find a copy of the manual. Superchargers need regular rebuilds around 100hrs. Could also be the belt from what I've read. What rpm is it running at that speed ?
I’m not sure...hopefully I’ll get it in the water in the next couple of days and see exactly what it’s doing.
 

·
Registered
Joined
·
4 Posts
From personal experience, you likely have a supercharger issue. The coating on the internal blades will breakdown. There won't be any noise or other noticeable issues, but your will top out in the upper 30s. I was able to find a good rebuilt supercharger and changed it myself over the winter. Just be sure to check out the intercooler as the material from the supercharger will end up in it and need to be cleared out. You will also want to flush the intercooler with de-greaser.
 
1 - 4 of 4 Posts
Top