Personal Water Craft Forum banner

1 - 20 of 104 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter #1
i have a 97 montego i am very new to jet skis this is the first time i started this guy up and it has a loud rattle sounds like metal on metal grinding rattling its coming from either all the way in back or underneith please help any ideas pleaseee
 

·
Registered
Joined
·
157 Posts
no just remove the 4 bolts on the back of the ski and the rubber water hose and everything will come out then i dont know if you have the update shaft that it screws to the motor or it just slids in to the motor but no matter what the shaft has to come out so you wont damage the bearing
 

·
Registered
Joined
·
64 Posts
Discussion Starter #7
cool so i pulled that whole back off the drive shaft just slid out however it wont let me pull all the way out its getting stuck somewhere but with that off motor sounds great no rattle so its somewhere in that whole back part
 

·
Registered
Joined
·
64 Posts
Discussion Starter #11
still not sure were the noise is comming from it sounded pretty hard like metal on metal impeller hitting ? bearing ?any guesses
 

·
Registered
Joined
·
157 Posts
you better hope its not your wear ring cuz its a $300 plus part. you must remove the prop with the housing so you can spine the prop by hand woth the prop next to your ear and listen if thats the sound you hear. lets not worrie about the wear ring right now so do that fist then i will tell you how to aline the motor
 

·
Registered
Joined
·
64 Posts
Discussion Starter #14
if im doin it right i dont hear any noise when i spin it by hand the only things i notice so far is the long rod thats conects to the impeller has play in it up and down not sure if thats normal the floating bearing seems to have a hairline crack starting the impeller has snall nicks in it
 

·
Registered
Joined
·
157 Posts
if you can remove the driveshaft and remove the floting bearing and turn the bearings with your fingers if its ok then see if your shaft is not bent and look at your motor coupler see if it does not have play
 

·
Registered
Joined
·
64 Posts
Discussion Starter #18
oh and i dont know if this helps but when i rev it up sound went away when it let off and it slowing down sound comes back
 
1 - 20 of 104 Posts
Top