Personal Water Craft Forum banner
21 - 40 of 104 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter · #21 ·
ok the motor part of the driveshaft has no play with the drive shaft back in and evrything put back together if i move the shaft left and right i hear the noise coming from the back
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #29 ·
no when all that stuff was removed the motor sounded fine when its all back together it makes that sound
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #31 ·
ok i will give that a try i will get back 2morrow and thanks for all the help so far your the only one who has helped me and thanks il get back 2 morrow
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #32 ·
engine doesnt have any play at all however while the drive shaft is connected to the impeller there is a ton of play there ? not sure how to get the drive shaft out of that
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #33 ·
put everything back together kindda hopin the problem would cure itself but nope makes same noise when its cranking then runnig im sure it comin from the back somewhere
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #36 ·
i think that might be it i finally got a txt back from the guy i bought it from he said he thinks the pump bearing was goin bad where do you get the rebuild kit from and is it hard to do ?
 

·
Registered
Joined
·
157 Posts
go to my website Tigershark and go to the hard to find parts page and click on all the links till you find the cheapest website that has the bearings and plus if you dont have a manual for your jetski you can also download it on my website for free. my website has all the info you need all for free let me know how it works out for you
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #38 ·
oh trust me your website is awsome i have looked at more than anything else in the last few days if im getting this right basically im replacin the bearings and seals ?
 
21 - 40 of 104 Posts
Top