Personal Water Craft Forum banner
81 - 100 of 104 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter · #81 ·
seems like the impellers moves kinnda hard to tell seems like the more greese i pump into the floating bearing the less rattle i get also i put some greese in that greese fitting towards the front where the shaft goes
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #85 ·
well the rattle is there when i have everything connected but the rattle went away when everything was off drive shaft impeller jet pump i dont think i can start it with just the jet pump off i did i a lil search on you tube
if you listen his has a similar rattle except mine is louder
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #87 ·
but the impeller and everything wont be connected it all skrew together with the 4 bolts doesnt it ?
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #91 ·
if im thinking of the right thing there is a long skrew that goes through the jet pump and skrew to the impeller
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #95 ·
hi
ok i got the pump off again no noise while running without it so i think im am down to wear ring or ???? i have no idea it only rattles when it runs rough when smooth no rattle but with pump off no rattle ever
 

·
Registered
Joined
·
157 Posts
ok on this last test your going to need another person to help you. put the pump back on and have your helper turn the driveshaft by hand. you will be at the back looking at the prop and wile your helper is turning the shaft look at the prop and wear ring and see if they are touching each other. if not then i have a quick temp fix for ya...
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #100 ·
would a bad wear ring make a noise and how do you know when they are bad i tried looking up stuff but couldnt really find anything
 
81 - 100 of 104 Posts
Top