Personal Water Craft Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
got the gp in the water today.......runs perfect out of the water, put it in the water and it falls on its face. after i put the free flow and the d plate in i hooked it up to the water I.V. and it ran good no leaks, started rite up, free rev through the r range. same today on the trailer until i put it in the water. the pump was clean and everything, any idea??? let me know thanks
 

·
Registered
Joined
·
209 Posts
got the gp in the water today.......runs perfect out of the water, put it in the water and it falls on its face. after i put the free flow and the d plate in i hooked it up to the water I.V. and it ran good no leaks, started rite up, free rev through the r range. same today on the trailer until i put it in the water. the pump was clean and everything, any idea??? let me know thanks

ok what all is on your ski again?

will it run in the water? or it dies when you hit it, or just bogs out?

i hope your not revving it past 4k on the trailer......

do you still have the accelerator arm on the carbs?
 

·
Registered
Joined
·
30 Posts
Discussion Starter #3
powerless

I have riva's free flow exhaust, and the d-plate with the sensor chip. I have never touched the carbs. it idles fine through the water but if you give it gas it just boggs out. when i got it in the water i idled it out to the middle of the lake made sure it had some heat on it then gave it some gas, it ran rite up on plane but i didnt give it full throttle, turned around and got on it and thats when it bogged out, from there on it will barely run. I was thinkin fuel filters or seperater but both look fine, im stumped. Unless i rip the carbs out and cleanem or rebuild them? but then i dont understand why it sounds good on the trailer. :dunno:
 

·
Registered
Joined
·
209 Posts
I have riva's free flow exhaust, and the d-plate with the sensor chip. I have never touched the carbs. it idles fine through the water but if you give it gas it just boggs out. when i got it in the water i idled it out to the middle of the lake made sure it had some heat on it then gave it some gas, it ran rite up on plane but i didnt give it full throttle, turned around and got on it and thats when it bogged out, from there on it will barely run. I was thinkin fuel filters or seperater but both look fine, im stumped. Unless i rip the carbs out and cleanem or rebuild them? but then i dont understand why it sounds good on the trailer. :dunno:
you said earlier that you could hear pieces of the cat in the waterbox? have you cleaned that out yet? to many pieces and it could cause to much back pressure,,,,,, have you done a compression test? clean out the fuel filter and water seperator,,,, take the fuel pick up off the tank and remove the trap door thats on the bottom,, sometimes this can block fuel delivery,, while your in there extend the fuel line down like 3 inches..... if you know your motor is in good shape, and the lines arent clogged, then the next step is to look at the carbs,,,,, do you still have the choke installed?
 

·
Registered
Joined
·
30 Posts
Discussion Starter #5
i havent done a compression test yet but it only has 104 hours on it. I removed and blew out all of the exhaust before it went back into the ski, and the choke is still on it i didnt know there was an advantage to removing it?
What do you gain by adding 3 inches to the hose?
Would it be a good idea to put new fuel filter and seperator in it anyway just because?
p.s. im still using yamalube even though i removed the cat, should i be running a differant oil? I run full synthetic amsoil in my viper.
 

·
Registered
Joined
·
209 Posts
i havent done a compression test yet but it only has 104 hours on it. I removed and blew out all of the exhaust before it went back into the ski, and the choke is still on it i didnt know there was an advantage to removing it?
What do you gain by adding 3 inches to the hose?
Would it be a good idea to put new fuel filter and seperator in it anyway just because?
p.s. im still using yamalube even though i removed the cat, should i be running a differant oil? I run full synthetic amsoil in my viper.
still do a comp test even though you only got 104 hours on it....better safe than sorry....

well with the primer kit installed, you can remove the choke plates inside the carbs, it helps the wind flow better, instead of going around a shaft.... not sure what the performance gains are but its a useless piece that can be taken out if theres a primer....

adding 3-inches on the hose will allow you to pick up the rest of the fuel thats on the bottom of the tank,, theres a few gallons that the stock lines dont get..

if the filter and seperator are clean and there still sealed good then i dont see why yo uwould need to replace them,,

forget the yamagoop..... use quiksilver from wal-mart.... i use it in my triple pipe gpr, and my EFI gpr.....it works great...
 

·
Registered
Joined
·
24 Posts
I took my ski out for the 1st time today... and it did exactly what you described pretty much to a T... SO here I am now.. Pulling things apart to make sure things arent clogged...
if you figure out exactly what it is, please post up.. I am new, but technically inclined.. Just might take me a bit more to fix mine.. I dont know much about 2 strokes yet..
BTW mine is the XL700...
 

·
Registered
Joined
·
209 Posts
BTW, Remy.. what are you talking about when you are talking about fuel pickup and the trap door?..
the fuel pick up is the unit thats in/on top the tank that supplys the motor fuel, its where the fuel level sensor is,,, on the gpr pickup theres a door/filter on the bottom of the unit in the tank, in order to extend the lines down this door needs to be removed..
 
1 - 10 of 10 Posts
Top