Personal Water Craft Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello folks. I'm new to the forum and also to jetskis. I picked up a 1998 1100 STX. It had water in the fuel tank, so I drained it out and then cleaned the carbs. The choke had been cut off by the previous owner. I changed the fuel lines (supply and return). I'm not sure if this was a good idea, but I put a primer bulb in the supply line. But I still have to spray carb cleaner in the carbs to get it to start. All that aside, the main problem I'm having is when I get it started and rev the throttle, then release it, the engine accelerates uncontrollably. Even pulling the lanyard and pressing the stop button doesn't shut it down. Anyone have any idea why it would accelerate like that? Thank you in advance.
 

·
Super Moderator
Joined
·
5,059 Posts
First problem is the choke was removed. That should not be done on the cv's. They don't like it. The idle screw may be adjusted for to high of a idle or a massive air leak somewhere making a lean runaway condition. Did you use new carb base gaskets ? You need to do several things to try and get those carbs to work, and then it's a guessing game to keep them from going lean. Your best bet would be to either get another good set of cv carbs, or convert to cdkII carbs. I believe all you will need is the carbs, and flame arrestor (actually the base), and make sure the rubber tubes are in good shape. The only issue with the cdk carbs is if the accelerator pump diaphragm goes out, there are no replacements available that I know of.
Get rid of the primer bulb. When the carbs are tuned right, it will start instantly.
When the cv's are running right, they are good carbs, just a little lean on the bottom end due to epa.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thank you for your response and advice. I thought it might be an air leak, but couldn't figure out where. I'll replace the choke and look into getting some carbs. I'll delete the primer bulb also. Thanks again.
 

·
Premium Member
Joined
·
28 Posts
First problem is the choke was removed. That should not be done on the cv's. They don't like it. The idle screw may be adjusted for to high of a idle or a massive air leak somewhere making a lean runaway condition. Did you use new carb base gaskets ? You need to do several things to try and get those carbs to work, and then it's a guessing game to keep them from going lean. Your best bet would be to either get another good set of cv carbs, or convert to cdkII carbs. I believe all you will need is the carbs, and flame arrestor (actually the base), and make sure the rubber tubes are in good shape. The only issue with the cdk carbs is if the accelerator pump diaphragm goes out, there are no replacements available that I know of.
Get rid of the primer bulb. When the carbs are tuned right, it will start instantly.
When the cv's are running right, they are good carbs, just a little lean on the bottom end due to epa.
Those diaphragms are included in almost every carb rebuild kit...

https://www.amazon.com/Keihin-Carburetor-Rebuild-Kawasaki-Polaris/dp/B008Z265D6

Edit - Maybe I'm not thinking of the accelerator pump

Edit 2 - Looks like my confusion came from the fact that my CDK-II's dont have the accerator pump.

https://www.keihin-na.com/assets/1/7/cdk_parts.pdf

Your mileage may vary
 

·
Super Moderator
Joined
·
5,059 Posts
Those diaphragms are included in almost every carb rebuild kit...

https://www.amazon.com/Keihin-Carburetor-Rebuild-Kawasaki-Polaris/dp/B008Z265D6

Edit - Maybe I'm not thinking of the accelerator pump

Edit 2 - Looks like my confusion came from the fact that my CDK-II's dont have the accerator pump.

https://www.keihin-na.com/assets/1/7/cdk_parts.pdf

Your mileage may vary

The cdk's on the 1100's do have a accelerator pump, no it does not come in the kit. There are still a few new floating around that show up every now and then, but they are getting scarce. Your probably thinking of either the fuel pump diaphragm or the regulator diaphragm.
If you would like to look, here is the part number. 43028-3710
I have though several times about getting a hold of Boyesen to see if they might have a quick shot system that would fit. Guess I should do that.
 

·
Premium Member
Joined
·
28 Posts
The cdk's on the 1100's do have a accelerator pump, no it does not come in the kit. There are still a few new floating around that show up every now and then, but they are getting scarce. Your probably thinking of either the fuel pump diaphragm or the regulator diaphragm.
If you would like to look, here is the part number. 43028-3710
I have though several times about getting a hold of Boyesen to see if they might have a quick shot system that would fit. Guess I should do that.

Looks like there's some similar diaphragms with shorter rods on them still available.

Push comes to shove you could always pay a local shop to turn down a press fit rod to match the factory length of the -3710 piece. That's assuming the -0001 diaphragm is the same size.
 

·
Super Moderator
Joined
·
5,059 Posts
Looks like there's some similar diaphragms with shorter rods on them still available.

Push comes to shove you could always pay a local shop to turn down a press fit rod to match the factory length of the -3710 piece. That's assuming the -0001 diaphragm is the same size.
That would be a viable option. really wouldn't need to be a press fit because the spring and actuator arm would keep it in place. The other thing with the accelerator pumps is their lack of efficiency, which is another reason it would be nice to get a Boyesen cover. Fills the chamber more for a better shot. I emailed Boyesen yesterday, so we'll see what they say. Crossing my fingers.
 
1 - 7 of 7 Posts
Top