Personal Water Craft Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 2000 Sea-Doo RX that I was hoping you could help me with. After not using it for a year, the battery died and wouldn’t hold charge. I replaced it with a new battery, charged it, and went to start up the jetski. However, when I put the lanyard key onto the little knob / post, the Sea-Doo did not give the usual two beeps (though the instrument LCD display did turn on to show the time). When I pressed the red start/stop starter button, nothing happened. Even after cleaning off the contacts inside my two keys, I couldn’t get the Sea-Doo to beep when either of the keys are attached.

I tried the advanced self-diagnostic test and here’s what happened: After five presses of the start button, there was a short beep followed by a long beep. Then, one of three things would happen:

1. Without putting the lanyard on, I press the start button: the ski beeps twice
2. I put on the lanyard, and then press the start button: the ski beeps twice (same as pressing the start button without putting on the lanyard)
3. Sometimes though, after I put on the lanyard and then press the start button, the ski beeps three times

What do these results mean?

Another thing I tried was shorting / jumping the starter relay in the rear electrical box. This caused the engine to turn over. Also, I checked all the fuses in the MPEM module and they were all okay. I checked the only fuse I could find in the rear electrical box and it was also okay.

To me it seems like the Sea-Doo “forget” the keys when it’s battery was dead for over a few months, and that it no longer recognizes their codes. The service rep at my local dealership told me over the phone that my starter relay is probably broken but I don’t agree with him because there’s a more fundamental problem here I think.

Hopefully someone can help me?!? Any advice would be much appreciated.
 
1 - 1 of 1 Posts
Top