Personal Water Craft Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I took it out and it ran well the first hour, then it starting bogging down. Finally I needed to be towed back in. Now it starts, but will only idle. If I give it a little Acceleration, it immediately dies. I changed out the Coil, same results. Cleaned the fuel filter, no change.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
2000 GTI 5647 Idles but won't Accelerate

It Is a Year 2000 GTI 5647. Someone told me that it might be gas starved. When I had it running last night I used a squirt oil can and shot some gas into the Carb as I slight accelerated the card. No Change. It still dies immediately when you accelerate.
 

·
Premium Member
Joined
·
1,054 Posts
It's got the 717 motor right? "5647" does not mean anything. It could a wealth of things.

1) Let's start with the obvious, is your fuel selector turned to the "ON" position? And do you have fuel in the tank? Sorry if this is too obvious but I saw a guy cranking a Yamaha ounce for 5 minutes only to realize his fuel petcock was off.

2) Fuel pump?

3) Internal carb filters clogged

4) Does it have the old grey "tempo" fuel lines, if so they need to be replaced and this could very well be your issue.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
How do you determine the engine size or number?

1) Gas Line is on, Fuel Filter is clean and gas is flowing.

2) Fuel pump? I assume the pump is internal in the card. How do you verify it is functioning?

3) It has a single Carb. Is this filter immediately after the Fuel intake line? There are two fuel lines going to the Carb. Where do I look for the internal Filter?

4) No, It has Black Fuel lines that appear to be in good shape. I had already read about this previously and I had cut a piece of line off and checked it out.
 

·
Registered
Joined
·
19 Posts
i know its a stupid question , but you haven't sucked a load of plastic in through the intake grate and its jammed the impeller ??

we have it all the time here as loads of shit in the water , i had to get a guy to tow my wife back yesterday from about 5km off shore as i could not get it out by hand .

this shows the same systems
 

·
Registered
Joined
·
2 Posts
Acceleration

The primary fuel filter is between the fuel selector and the Carb intake. You can access that filter from the front of the ski, after removing the front storage compartment.

The internal fuel filters are in the carb itself. You have to remove the carb and do a little tear down to clean that up.

If some dirt/debris did manage to find it's way into the carb, then you could have some clogging in the jet's.

I do agree that you may want to check for obstructions in the prop, and drive shaft alignment.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
Well, just to be sure, I removed the jet pump. No Obstruction and the propr moves freely. Gas seems o be moving freely also through the Carb. No dirt in the fuel filters. Anu other ideas? Same responce from my engine. Starts, idles, when I give it the least amount of throtle it dies.
 

·
Premium Member
Joined
·
1,054 Posts
Did you find the internal carb fuel filter? If not here is a diagram to help you. It's part number 7 on there. Looking down at the carb there is a cover with four screws. Unscrew those, take the cover off, and there is a black plug like thing in there that is the filter. Remove it with needle nose pliers if you can't with your fingers. If its dirty use some carb cleaner spray to spray it out.

http://www.mikuni.com/pdf/sbn_rebuild-kit.pdf

Is your compression good? The 2000 GTI has the 717 aka 720 motor which should have 145-150 PSI of compression.

If all this pans out you probably need a carb rebuild kit. Your watercraft has a Mikuni BN 40-38 carb.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #11
Final Solution

In the end I finally have the answer to my problem. The sprocket for the ROTARY VALVE was stripped. I brought a new spocket assembly and installed it and the jetski is running well again.
 

·
Registered
Joined
·
7 Posts
clean the carbs good, and look for water/phase seperation in the fuel.... I just removed 8 gallons of bad fuel from a tiger shark doing the same thing... I flushed the fuel lines and it runs fine....
 

·
Registered
Joined
·
1 Posts
i have a seadoo spark 2 90ho........i have put everything on it to go faster but this weekend the throtell was acting up it would rev up and down ......i think it has to be a electrical problem because it has no throtell cable just a harness connecting it ?????? any one has had this problem.
 
1 - 15 of 15 Posts
Top