Personal Water Craft Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi,

I´m fairly new to the PWC world, but I bought a Seadoo XP limited 1998 jet ski last year. I´ve had plenty of fun with it already and I just love riding jet skis.:)

But last day when I took it out for a spin, the fuel gauge suddenly stopped working (showing empty tank, depsite tank being nearly full) A long beep sounded and I stopped the ski. And tried to investigate, couldn´t find anything unsual though. :confused:
So I started it up again, but the gauge still didn´t work and every now and then, this long beep sounded, but othwerwise the ski ran just fine.

Checking the manual for trouble shooting in terms of this beep, it says, check your lanyard connection, but it is fine...

Any advise on the faulty fuel gauge??


rgds
Michael
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
problem solved

Problem sorted. It turned out to be a faulty fuel baffle.

I suspected that either the magnets on the float had become loose or the float it self was not able to float anymore (common problems). But it turned out (unfortunately) that the baffle was faulty.. Fairly expensive part, but I just realized it is possible to repair it your self. The typical problem with the baffle is a small 1 A fuse on the print card that fails. If you replace this fuse, (or simply shorten/bypass it) the baffle will most likely work again.

rgds
Michael
 

·
Registered
Joined
·
2 Posts
I just took out baffle, f1 fuse removed (jumper) used multimeter when on lines inside baffle,slide magnet went to 0. But when ohm @connection no reading?
 
1 - 3 of 3 Posts
Top