Personal Water Craft Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Help!!! I have a 97 SLT780 that will not start, does anybody know where I can get a wiring schematics for it? I am an electronics installer and repar person but have never worked on a jet ski. I am trying to figure out why it will not get fire to the plugs without just replacing everything. (cdi, voltage regulator,etc...)
 

·
Registered
Joined
·
37 Posts
I have a pair of '97 SLT780's :) - 1) Have you tried new plugs? 2) Have you checked to make sure all fuses are OK 3) Is the engine turning over but you're just not getting spark at any of the 3 plugs? More details would help?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Thanks for replying, I have checked and I am getting no spark on all 3 plugs, yes it spins over fine, and I only found 2 fuses in the electrical box. one fuse (1/4amp)that runs the electronic gauge was bad, replaced and it still dont start. (no fire on plugs) The gauge was not functioning prior to this and I cant buy a replacement since it don't exist anymore. I would love to have it working, but get the pwc running is first priority. i have another slt780 (1yr newer) I am going to compare voltages wire by wire (long process) if nothing else. Where is the 3rd fuse? in the electrical box?? I only saw 2 and both are good.
 

·
Registered
Joined
·
37 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Sorry, guess I shouldn't speed read :) I just bought the pwc's from a relative, he had purchased them from the original owner about 6 years ago, he is a professional mechanic at kingsland tx. He has well maintained them and they were both running great when I got them july 4 th weekend. I have taken them to the lake before I purchased them several times and had no problems. the only thing I had wrong was the MFD on one wasn't working. Since then The other MFD on the 2nd slt780 quit also. That is my fault though, I swapped the gauges between the two and now neither one work!!! Shouldn't have done that but stuff happens. Both were running fine without the MFD's working, and the one in question run fine until last sunday, rode all day on both, went to load it up and it would not start. Checked the obvious, gas, oil, no water inside (very little) checked connections on cables, wires, etc.... The Slt780 has run fine up until this. Hopes this help with any suggestions on what could have happened and thank's for the tip on ebay for the MFD, I saw the pricetag new and gheesh!! gonna have to sell ALOT of blood for that! ha ha Any help would be greatly appreciated.
Tom.
 

·
Registered
Joined
·
37 Posts
Ok - The add'tl info. helps :) but Not to the point where I'm going to be able to tell you what the problem is :( I don't think you harmed anything by switching MFD's - unless somehow something got shorted out in the process? For all 3 plugs to quit at the same time leads me to think maybe the CDI did get fried. How about trying to swap out the one from the other machine to this one?? I would make sure and unhook a battery cable before doing any work on the electroincs. (Oh - this is from another Tom :))
 

·
Registered
Joined
·
5 Posts
I am having the same problem and many have told me check the Stator coil windings. the stator and cdi are a common problem with those. mine rode fine all day. hard starting right before i took it to the ramp, then once at the ramp no start..funny how these all die the same way and time hah. here is a good post from another site that will explain to you how to test each of the circuits if u are comfortable doing this....this site is full of helpful info on any ski and many people there know alot about them thats how i troubleshooted mine.
How to test CDI, Magneto stator coils & Ignition coils on Fuji engines - Green Hulk Personal Watercraft Performance Forums
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
Thank you for the info, I am ready to get them out and start attempting to find the problem. With summer almost here I have been looking forward to getting out to the lake for some fun. This will at least give me a starting point on repair. I do appreciate the info very much!:)
 

·
Registered
Joined
·
85 Posts
I Have A Working Stator
Cdi
Coils

All Pulled From A Running Ski

Please Call If You Need To Place An Order

North Florida Pwc And Parts
Nick F
Jacksonville,fl.32218
904-755-4693
7 Days A Week
8am-8pm
 
1 - 9 of 9 Posts
Top