Personal Water Craft Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
yes i said jet pump lol.....fits on the driveshaft and in the wear ring perfectly but i am unable to get it onto the jet pump....i have a 1999 TS770R and just bought a solas Impeller (model TB-SC-I-15.5/19.5) which the chart said would fit my model....anyway....when im installing the new impeller onto the impeller shaft i can tighten it till it hits the small area on the jet pump thats supposed to go inside the base of the impeller, i tried my hardest to get it over it but it just wont fit.....


so i figured i would just get it as tight as i can and install it and see if starting the motor would break it free.....well it didnt...the motor wouldnt even turn over due to the friction and made a loud squell when it tried...any idea why this is doing this??? is it the wrong impeller???.....the old one goes on like a champ with no problems....picture below of old one


and the part where it is rubbing with the shaft out and no impeller....
 
1 - 1 of 1 Posts
Top