Personal Water Craft Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
This is a weird one. The WaveRunner (2001) has been garaged for about a year+. I pull it out and it does nothing. Well, the warning light comes on when I do connect the battery. I figure the battery is bad, so I go ahead and pull it to the coast, and get a battery on the way. Charge the new battery, and get the same thing, warning light comes on shortly after connecting the battery, absolutely nothing after that.

So I think the battery might not have enough charge, run up and buy some jumper cables. When I get back and reconnect the battery, I don't get a warning light. The engine turns over and spins, but because the cylinders are dry, it doesn't fire. I've had this problem before, and easily solved it by removing the plugs and adding some gas to the cylinders.

Back to the store, buy a gas can and some gas, get back and the warning light comes on immediately upon connection. Nothing will happen after that light comes on start wise. Disconnect and mope a bit.

OK, so I go get dinner, come back, and trying to be smarter than the machine, I put some gas in the cylinders before I connect the battery. Connect the battery, no warning light, hit the switch, starts right up! I run it a little, but because I haven't connected any water, I don't run it long, maybe a minute.

As soon as it shuts down, that [email protected]#$ warning light comes back on! Again, it acts like it is dead. As I once again disconnect the battery, I come across another clue. If I hold the start button, and connect the battery, the engine will attempt to turn, only to be locked out by the warning light.

So, some sensor must be telling the engine not to fire?

A couple of years ago I removed the damaged catalytic converter when it came loose and blocked the exhaust. I replaced it with the D-plate and temp sensor from Riva.

I apologize for being long winded, but I did want to provide as much info as possible in search of a solution.
 
1 - 2 of 2 Posts
Top