Personal Water Craft Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter #1
Need help here. Have a Yamaha 800 XL, last time on water ran fine for first part of day, took a break, tried to start on no luck. I checked the plugs and they were a little bit fouled, sanded them a bit, put them back in but still not starting. Not sure what else to do, I am not too familiar with the ski so not sure location of carburators ect. Any ideas?
 

·
Registered
Joined
·
41 Posts
Discussion Starter #4
ok guys, got it started using starting spray, I know I should not use this or use it much. Once started it works fine but it is not quite idleing right and if you let it die out it will not start again without spray. I guess this is the carburetors need cleaning, correct?
 

·
Registered
Joined
·
41 Posts
Discussion Starter #6
took it to lake today, ran great for about 300 yards then started bogging down then stalling. Could restart pretty easily and would run for a couple hundred yards then same thing. Eventually would not start and had to tow it back. What is a fair price to have the carbs re-done?
 

·
Registered
Joined
·
41 Posts
Discussion Starter #9
Took ski to a mechanic, was going to leave for him to rebuild carbs, he calls and said one of the cylinders does not have good compression and needs to be rebuilt. I told him the symptoms of the ski seamed to be carburetor related. He said a bad cylinder would have similar symptoms as far as the ski starting then stalling after a few hundred yards, said the cylinder probably locks up and freezes it from running and shuts down. Does this sound right to you guy? I also noticed when I started it last I did not have water pissing off the left side of the ski as you are sitting on the ski.
 
1 - 20 of 21 Posts
Top