Personal Water Craft Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Help... This is what I have checked so far and no change in this problem. Check compression it was 125 psi, Replaced spark plugs, Clean and replaced fuel, Check timming it was 24 deg adv, Found fuel line was spilt coming from tank to pump and fix, Checked inpella and you can turn with hand, Carbs were rebuilt and new reeds were replaced. Any other suggestion that I could check.. Thanks.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #2
Anyone's help would be nice

Tiger shark 900 will not run over 30 mph
timing good
compression good
fuel pressure good
new sprak plugs
Impella good
 

·
Registered
Joined
·
15 Posts
So you have the throttle wide open and it doesn't bog like the carbs are dirty? Have you actually cleaned out your gas tank ? I had a big problem with mine and come to find out, after talking to a mechanic, he mentioned cleaning the inside of the tank. I kept getting debris in my carbs from a dirty tank. You wouldn't believe all the trash i pulled out of there.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
I have drain all the fuel from the tank and replaced fuel filters as well.. Still the same.. I think I might check behind the mechanic that said he rebuilt the carb and replaced the reeds.. He may have taken me for a ride...... I guess I need to check the jet pump as well.. Thanks..
 

·
Registered
Joined
·
15 Posts
most mechanics that rebuild carbs will show you all the old parts for your piece of mind. See if they still have all that stuff, that way you know. Change your jet pump oil see if that works. It almost sounds like your throttle isn't rigged right.
 

·
Registered
Joined
·
27 Posts
what you do is fill the inside of the jet ski with salt water and let it sit for a few days then drain it and it should work.......
 
1 - 8 of 8 Posts
Top