Personal Water Craft Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1 (Edited)
I Have 7 Or 8 1994-1997 Polaris Slt,sl,ect. That Ive Been Parting Out!!!!

I Have Alot Of Different Parts And A Reasonable Price!!!!

I Cant List All The Parts I Have So Please Email
For More Info.

Thanx For Looking

Located In Kalamazoo, Michigan
 

·
Registered
Joined
·
11 Posts
Need A "Black Box" for a SLTX 1050 Polaris

I have one here that is having a dead short somewhere.....

I can't quite figure it out. Customer brought it to me saying it was having starting issues and the MFD was not working......

He had two batteries he brought as well.....

The newest one was just charged he said, so I checked it with a fluke and it only had 9v - obviously toast.

So I checked the other battery, get a load of this - it had reverse polarity!

I had the red wire of my fluke hooked to the pos. and the black to the neg.

It was fully charged, but I had a negative 12.6 v reading!

I put a new batt in, and it started right up...ran fine......about 30 minutes later the battery was dead. I did a draw test, and there is a huge draw coming from somewhere. It sparks like hell when you touch the cable to the batt. It kills a new battery pretty quick.....

You can do an ohms test on the pos and negative cable - and there is no resistance, meaning there is a dead short somewhere. I have traced all the wires and found nothing obvious...... I opened the black box and it was full of water.....

I am lost.....

I even tried to get a resistance reading between the lugs on the starter solenoid, and again there is no resistance........however when I hook a fully charged battery to it, the solenoid works fine, and the boat starts normally....

Where do I begin?

I called you and left you a message......
 

·
Registered
Joined
·
12 Posts
Discussion Starter #3
i dont have a black box but...

i would start by checking all the wiring and see if there might be a nick in any wires. then go through and check the power before and after all of the parts in the black box and if nothing jumps out to you as be bad then i would say it might be a stator problem..that is only a guess???? but yeah i havent seen any problem like that before either...just take you time and go through the whole electrical system and something should be bad..
goood luck
eric
 

·
Registered
Joined
·
3 Posts
96 slt 700 lower end

need crank/case, 2 rear motor mounts and starter shipped to florida zip 32157. please advise condition and cost.

randy in florida
 

·
Registered
Joined
·
1 Posts
Wiseco STD Piston for 1994 Polaris SL 650?

Need the rings to. Do you have one? I believe it is 65.50mm Stamped A9017 on top. Let me know.
Thanks, Joey
 

·
Registered
Joined
·
1 Posts
Need piston, cyl, and steeing cables Polaris 750sl 750

Hi, I am looking for piston and cyl for 1993 polaris 750 sl. My other cyls have been bored out to 70.25 and have Wiseco pistons. Any matches??

I also need two steering cables for the same machine.

need condition, cost and shipping to Southern Calif.

Thanks
dave
 

·
Registered
Joined
·
2 Posts
looking for driveshaft/coupler for my 1995 SL750. Do you have any?

I Have 7 Or 8 1994-1997 Polaris Slt,sl,ect. That Ive Been Parting Out!!!!

I Have Alot Of Different Parts And A Reasonable Price!!!!

I Cant List All The Parts I Have So Please Email
For More Info.

Thanx For Looking

Located In Kalamazoo, Michigan
dfadsDSdsSfafFAA
 
1 - 16 of 16 Posts
Top