Personal Water Craft Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hello my vx sport wont rev past 7000 what can be the problem? I have new plugs and oil and oilfilter. Thanks for some help.
Sorry for bad spelling im from sweden :)
 

·
Registered
Joined
·
30 Posts
Check your air filter. I had this issue with my 05 VX110 when someone did an oil change & added to much. Filter was saturated in oil & restricted air flow. I couldn't get past 6000 rpm's. I open filter box to find small puddle of oil. I bought a new filter & sucked out excess oil from oil tank. Ran up to 8000 rpm's right away. Hope its that simple for you.
 

·
Registered
Joined
·
30 Posts
Also check oil level when hot. (Either running it in the water for 10 minutes or hooked up to a hose while running) Jet needs to be level when checking. How did you change the oil & how much oil did you replace?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
I have tried and run wihtout air filter but no diffrent :-( I used a pump to remove the oil and added about 2L off oil.
 

·
Registered
Joined
·
30 Posts
I would do a compression check of each cylinder, also check all wire connections, make sure spark is going to each plug. Check your fuel for water in tank. You can siphon out & replace or buy the sock that you drop in your tank & absorbs the water in the gas (safest way).
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
Hello i have checked The compression and it was 12,5 kg on all four. I have used contact spray on all connector butt on the cable shoes. I have used fuel additiv that should remove water.
 

·
Registered
Joined
·
30 Posts
Question did it rev up to 8,000 before? What speed are you seeing on the display when at 7,ooo rpm's. In other words could the tachometer read out be incorrect?
 

·
Registered
Joined
·
30 Posts
Okay so Plugs are good, spark is positive, no air flow restrictions, wiring looks good, Oil good. Cylinders are up to par for compression. So we are getting air spark & compression. The other thing I would think of would be fuel delivery. Fuel pump function should be checked. I am not sure though what the procedure for that is outside of hooking up fuel pressure gauge & running it WOT & see what the reading is. I'd would assume that the plugs were the correct replacements & coil packs are okay.
 
1 - 12 of 12 Posts
Top