Personal Water Craft Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
:confused:The water jacket on the side of the hull. How in the world do you check to see if it is spraying water? any suggestions?
 

·
Registered
Joined
·
14 Posts
Discussion Starter #4
Well i have only had this ski a couple of weeks. i have checked everything i can for proper function. at idle (in the water) i cant see or feel water spraying, and i have tried to look and feel the outlet while giving it throttle (still cant tell) now i have only flushed the ski one time and didnt notice any water exiting that port. is it a constant stream like most boat outboards? thanks for the help!!
 

·
Registered
Joined
·
42 Posts
I only flushed mine once so far, and was a little concerned when the water only spit out of the port side outlet. Then I reread the manual and it says run the motoer making sure water comes out the main jet exahust. The water may not exit out the port side outlet at idel, only when the engine is spun up. That's just a guess, maybe someone with more experience with the ski can comment. I just know I was able to see a good stream of water coming out of mine while I was underway.
 

·
Registered
Joined
·
323 Posts
You wont see water coming out at idle. The water outlets are located on either side under the gunnel in line with the handle bars. They are hard to see working but they have an overheat sensor which will let you know if its getting hot so dont stress.
 

·
Registered
Joined
·
42 Posts
You wont see water coming out at idle. The water outlets are located on either side under the gunnel in line with the handle bars. They are hard to see working but they have an overheat sensor which will let you know if its getting hot so dont stress.
Outlets? I thought there was only one, on the port side. I'll have to check...
 

·
Registered
Joined
·
14 Posts
Discussion Starter #8
There is a overheat feature that will turn the warning light on and sound the buzzer. if the engine is overheating and even reduce engine rpms. but the onlywater outlet is on the left side (sitting on the ski) below the gunnwale (vx models). as i mentioned im not sure if the one on my ski is working properly although i have had no overheating problems. i will get to the bottom of it this weekend.
 

·
Registered
Joined
·
42 Posts
There is a overheat feature that will turn the warning light on and sound the buzzer. if the engine is overheating and even reduce engine rpms. but the onlywater outlet is on the left side (sitting on the ski) below the gunnwale (vx models). as i mentioned im not sure if the one on my ski is working properly although i have had no overheating problems. i will get to the bottom of it this weekend.
I rode mine for an hour after work yesterday. While riding, if I bend over a little and look in that general area I can see the water coming out and hitting the lake water. I was able to reach down and feel the water coming out while riding, it was warm to very warm.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #11
Your right, but if it is not pumping water correctly it could lead to some problems in the future. and im not even sure its not working just have'nt noticed it. but like i said i will check it out this weekend and let you know what i find.thanks
 

·
Registered
Joined
·
14 Posts
Discussion Starter #12
ok i rode the ski this weekend for about thirty minutes (no cooling water spray at all!!!!!!)
so i took that hose off and blew it out, still nothing. i let it sit for a few hours fired her up and took it out and the thing started spraying water after about five minutes. all i can figure is there was some trash in the line. its working now and im happy. thanks
 

·
Registered
Joined
·
42 Posts
ok i rode the ski this weekend for about thirty minutes (no cooling water spray at all!!!!!!)
so i took that hose off and blew it out, still nothing. i let it sit for a few hours fired her up and took it out and the thing started spraying water after about five minutes. all i can figure is there was some trash in the line. its working now and im happy. thanks
Weird. I did notice now that I have had mine for a few weeks, and have flushed it/checked the oil several times that water does come out the port side hole pretty good even at idel speed hooked up to the garden hose.
 
1 - 13 of 13 Posts
Top