Personal Water Craft Forum banner
1 - 1 of 1 Posts

· Registered
1 Posts
Discussion Starter · #1 ·

I have a 1996 Waveraider 1100 Triple. So, I bought it two years ago and it ran great. I parked it and the end of the summer and haven't touch it again until today(it sat for ballpark 1.5 years). So, today, i tried to get it running and it idles great...fired right up. But, when i try to rev it up, it revs up for like 1/3 of the throttle range and then kind of won't rev any kind of misfires.

I removed the flame arrestor and metal grating and tried to rev it up. I noticed that the rear most cylinder is backfiring out the carburator. Any idea what might cause this? I am guessing the carburator is gummed up from sitting.

Also, I noticed that some folks run slightly hotter spark plugs on the Waveraider 1100s than is recommended. I installed brand new plugs...proper heat range. Should i move to one heat range hotter?

1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.