Personal Water Craft Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 1995 Waverunner III and it has a problem. Last year, I was riding it and it just quit. Would not crank. I figured it must be a battery since it was installed in 2004. Replaced the battery and spark plugs (yearly maintenance) and it ran fine for 10 to 15 minutes.

Now, it just dies. It will run for 30 seconds and they just die. Sometimes it will crank and start, other times it will not crank for 30 seconds then crank and start fine, run for 15 seconds or so and then die again.

Any suggestions? Over heating maybe? I'm confused by the not cranking part. Any help would be appreciated.
 

·
Registered
Joined
·
3,033 Posts
Carb/fuel problem? Has the carb been rebuilt? Spark plugs fouled? Poor compression? Stuck valve? Lots of possiblities.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
The way it stops I almost think it could be the stop switch. Sometimes it will not turn over for a few minutes (like the battery is dead) and then it will. It will run for 10 seconds and then quit again. It has good compression and whn it runs (typically first thinng of the day it will run for 15 munites perfectly) it gets to speed and has no bogging. That's why i think the compression is good and the carbs are clean enough. I would gues a fuel problem except that it has that problem turning over.
 

·
Registered
Joined
·
12 Posts
Check the overheat switch, my 1992 650 would start than die after 5 minutes and would not start,I would have spark for the first few turns than none,I would let her sit for a hour and would start up and again die, check that you have spark always as turning over. If your starder is not working I would check the overheat switch for sure or kill switch. It turn out in my case that it was the CDI,got the entire box with CDI on ebay for $150.00 dealer price for CDI $340.00, and I think the guy has another one for sale,hope this helps, Bornfree
 
1 - 4 of 4 Posts
Top